Bug 23654 - B43 chipset support
B43 chipset support
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.4 (2008.09)
All All
: high critical
Assigned To: Wang Zhenyu
Xorg Project Team
: patch
Depends on:
Blocks: miss-2.6.31
  Show dependency treegraph
 
Reported: 2009-09-02 11:39 UTC by Fabian Henze
Modified: 2009-09-11 00:28 UTC (History)
0 users

See Also:


Attachments
Xorg.0.log (7.83 KB, text/plain)
2009-09-02 11:39 UTC, Fabian Henze
no flags Details
dmesg output (22.70 KB, text/plain)
2009-09-02 11:40 UTC, Fabian Henze
no flags Details
lspci -nvv (16.45 KB, text/plain)
2009-09-03 04:53 UTC, Fabian Henze
no flags Details
My first try to add the pci ids myself. For the 2.6.31-rc8 vanilla kernel. (see comment #5) (3.72 KB, patch)
2009-09-05 16:10 UTC, Fabian Henze
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Henze 2009-09-02 11:39:26 UTC
Created attachment 29110 [details]
Xorg.0.log

System environment:
-- chipset: B43
-- system architecture: x86_64
-- xf86-video-intel/xserver/mesa/libdrm version: 
-- xf86-video-intel version: 2.8.1
-- xserver version: 1.6.3
-- mesa version: 7.5
-- libdrm version: 2.4.12
-- kernel version: 2.6.31-rc8
-- Linux distribution: Gentoo
-- Machine or mobo model: Intel DB43LD mainboard
-- Display connector: VGA

Reproduce steps:
I don't think I have to explain all the steps here. The problem is simple:
The PCIID of the X4500 with B43 chipset is missing in the kernel and the ddx driver sources.

Attachments:
I started X without xorg.conf
I will attach Xorg.0.log and dmesg output
Comment 1 Fabian Henze 2009-09-02 11:40:19 UTC
Created attachment 29111 [details]
dmesg output
Comment 2 Gordon Jin 2009-09-02 18:47:54 UTC
Thanks for the report. 
This is the first time I heard B43 chipset. But it does exist and uses X4500:
http://www.intel.com/products/desktop/motherboards/DB43LD/DB43LD-overview.htm

Let Zhenyu to check spec.
Comment 3 Wang Zhenyu 2009-09-02 20:31:17 UTC
Fabian, could you attach lspci -nvv output? or would you try to add pci ids in kernel agp/intel, drm/i915, xf86-video-intel, and mesa? I can help on if you have issue to add them.
Comment 4 Fabian Henze 2009-09-03 04:53:11 UTC
Created attachment 29173 [details]
lspci -nvv

I attached the lspci -nvv output. I can't add the pci ids on my own due to a lack of free time in the next few days and weeks, but I am willing to test patches.
Comment 5 Fabian Henze 2009-09-05 16:04:40 UTC
(In reply to comment #3)
> Fabian, could you attach lspci -nvv output? or would you try to add pci ids in
> kernel agp/intel, drm/i915, xf86-video-intel, and mesa? I can help on if you
> have issue to add them.

Well, I ignored my schedule for bit and tried to patch the agp/intel and drm/i915 part in the kernel to get KMS support, but dmesg gives me:

Linux agpgart interface v0.103
[drm] Initialized drm 1.1.0 20060810
i915 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
i915 0000:00:02.0: setting latency timer to 64
[drm:drm_fill_in_dev] *ERROR* Cannot initialize the agpgart module.
[drm:intelfb_restore] *ERROR* Failed to restore crtc configuration: -22
DRM: Fill_in_dev failed.
i915 0000:00:02.0: PCI INT A disabled
i915: probe of 0000:00:02.0 failed with error -22


I will attach my patch to the 2.6.31-rc8 kernel. You can also contact me in the #intel-gfx irc channel to speed up patch testing cycles, my irc name is Flyser.
Comment 6 Fabian Henze 2009-09-05 16:10:34 UTC
Created attachment 29258 [details] [review]
My first try to add the pci ids myself. For the 2.6.31-rc8 vanilla kernel. (see comment #5)
Comment 7 Wang Zhenyu 2009-09-06 18:45:37 UTC
Looks you missed the intel_i965_get_gtt_range() for B43.
Comment 8 Fabian Henze 2009-09-07 06:02:34 UTC
I applied all of you patches (http://lists.freedesktop.org/archives/intel-gfx/2009-September/004066.html and following) to the following versions:
Kernel 2.6.31-rc8
libdrm 2.4.12
mesa 7.5.1
xf86-video-intel 2.8.1
And they seem to work fine with KMS support enabled :-)
Do you think I should switch to some git versions of mesa or the ddx, as the X4500 is fairly recent?

Thanks a lot. (Closing as fixed)
Comment 9 Wang Zhenyu 2009-09-07 18:01:50 UTC
Apply to stable releases is just fine, and as our driver rearch has settled down, using git tip is also ok and we must be sure no break on that.

Thanks for report it and testing!
Comment 10 Gordon Jin 2009-09-07 18:16:28 UTC
Fabian, thanks for your effort.

Let's keep this bug open until all the patches committed.
Comment 11 Gordon Jin 2009-09-11 00:28:43 UTC
We can close this now since all the patches have been committed.

xf86-video-intel: in 2.8.99.901.
mesa: on master, mesa_7_6_branch, mesa_7_5_branch.
libdrm: on master, will be in 2.4.14 release.
kernel: on drm-intel-next. missing 2.6.31.