Bug 23693 - KMS has been broken on ATI RV250 Lf (Radeon M9)
Summary: KMS has been broken on ATI RV250 Lf (Radeon M9)
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-03 17:23 UTC by Johannes Obermayr
Modified: 2009-10-10 08:02 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Kubrick's crash (21.09 KB, text/plain)
2009-09-19 18:09 UTC, Johannes Obermayr
no flags Details
modprobe.log (12.23 KB, text/x-log)
2009-09-25 10:26 UTC, Johannes Obermayr
no flags Details
Gluon's crash (7.62 KB, text/plain)
2009-10-08 15:26 UTC, Johannes Obermayr
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Obermayr 2009-09-03 17:23:35 UTC
Kernel 2.6.31-rc8 and nouveau/linux-2.6 (and installed firmware)

Up to

author:    Roel Kluin <roel.kluin@gmail.com> 2009-08-29 20:20:34 (GMT)
committer: Dave Airlie <airlied@redhat.com>  2009-08-30 23:09:29 (GMT)
commit:    1ae70072f0699916c1a77a9bacad958ee46f7395

- KMS works


Since

author:    Ben Hutchings <ben@decadent.org.uk> 2009-08-29 13:53:51 (GMT)
committer: Dave Airlie <airlied@redhat.com>    2009-08-30 23:09:30 (GMT)
commit:    70967ab9c0c9017645d167d33675eab996633631

- KMS is broken
- While booting: I see "Loading drivers, configuring devices:" and then should come the "switch" to "smooth graphic" but it comes a black screen (init 3 and 5)
- An external connected monitor losts then the signal (maybe laptop display, too)
- I have to press the power switch until hard shutdown
- If I "tell" grub "nomodeset" the system boots...


If you need some debugging things tell me how I can provide it...
Comment 1 Johannes Obermayr 2009-09-16 14:42:26 UTC
It works again...
Comment 2 Johannes Obermayr 2009-09-19 18:09:07 UTC
I have to reopen this bug.

What happened:

Monday:
- Update kernel 2.6.31-rc9
- Update nouveau/linux-2.6 git 9030692aaff66fe3531828f6cc87ac0cfc06d798
- glxinfo increased from ~ 650 FPS (above working git) to ~ 1700 FPS.
- KDE's Kubrick crashed (see following attachment)

Tuesday:
- Update Mesa 20090915-0103 (CET)
- Update xf86-video-ati 20090915-0021 (CET)
- Kubrick crashed

Wednesday:
- Update kernel 2.6.31-rc9 (because of openSUSE build service rebuild)
- Update Mesa 20090916-0001 (CET)
- Kubrick crashed
- I closed this bug as "fixed"
- I wrote an email to Pauli Nieminen and he asked me whether I can say which commit crashed it.

Thursday:
- Update Mesa 20090916-2142 (CET)
- Kubrick crashed
- Starting bug hunting in Mesa -> back to a known working version -> Kubrick crashed
- back to nouveau/linux-2.6 kernel modules commit 1ae70072f0699916c1a77a9bacad958ee46f7395 -> Kubrick worked
- Update to kernel 2.6.31
- Tried compiling latest kernel modules -> need some kernel symbols (asked on opensuse-kernel mailinglist for help)

Friday:
- Received email from Jan Oertel -> Had to set CONFIG_DRM_KMS_HELPER=m
- Compiled latest kernel modules again -> Booting only with "nomodeset" -> old bug...
- Compiled kernel modules commit 9030692aaff66fe3531828f6cc87ac0cfc06d798 -> Booting only with "nomodeset"
- Compiled almost all commits back to known working -> commit 1ae70072f0699916c1a77a9bacad958ee46f7395 is the last working
  

So what can I say:
- commit 1ae70072f0699916c1a77a9bacad958ee46f7395 is the last working
- kdm.log tells me that I have had only modesetting with commit 1ae70072f0699916c1a77a9bacad958ee46f7395 since Monday
- I had no helper symbols on Monday but an increasing framerate in glxgears of more than 160 percent but a bug in Kubrick and no modesetting?
- Version of Monday was only working until an update
Comment 3 Johannes Obermayr 2009-09-19 18:09:57 UTC
Created attachment 29706 [details]
Kubrick's crash
Comment 4 Alex Deucher 2009-09-20 22:29:23 UTC
Please open a different bug for kubrick as this bug was about modesetting not working on KMS which appears to work for you now.
Comment 5 Johannes Obermayr 2009-09-21 02:28:05 UTC
No, KMS is not working for me:

"kdm.log tells me that I have had only modesetting with commit
1ae70072f0699916c1a77a9bacad958ee46f7395 since Monday"

The system does not boot with another version after this commit.

I thought that it worked with the one compiling on openSUSE Build Service as I described with crashing Kubrick - this is something mystic for me. But as said kdm.log tells that it did not.

The system is only booting with "nomodeset" at the moment.

"Kubrick's crash" was only attached because I thought that you can maybe see something related in it..
Comment 6 Johannes Obermayr 2009-09-25 10:26:36 UTC
Created attachment 29848 [details]
modprobe.log

I waited until Dave Airlie's git tree was merged in and compiled it then again (including commit db3a11a9ca27776ebe1e1b285a9c9123c7f18983).

The Bug is still alive.

So I did:
init 3
rmmod radeon
strace -o modprobe.log modprobe radeon modeset=1

I hope you can see something in it...
Comment 7 Johannes Obermayr 2009-10-08 09:40:36 UTC
KMS on console (init 3) has worked again since

author    Ben Skeggs <bskeggs@redhat.com> 2009-10-06 04:27:25 (GMT)
committer Ben Skeggs <bskeggs@redhat.com> 2009-10-06 04:27:25 (GMT)
commit    57e80de6515003f46762c6d0359ba957b179aeb8

Merge branch 'drm-next' of git://git.kernel.org/pub/scm/linux/kernel/git/airlied/drm-2.6 into nouveau


Thanks...

But if I try starting something with X (kdm/kde4, SaX2, ...) I can only see a very bad screen (see http://www.freeimagehosting.net/uploads/de9994204f.jpg). Mostly there are no lines but - I think - millions of points (pixels) distributed over complete screen which firstly change and then seem to stay...  

I have latest git installed:
mesa/drm
mesa/mesa
nouveau/linux-2.6 (only kernel modules and kernel 2.6.31)
xorg/driver/xf86-video-ati
Comment 8 Alex Deucher 2009-10-08 09:45:56 UTC
Does disabling AGP or changin the AGP mode help?  E.g.,
modprobe radeon modeset=1 agpmode=-1
Comment 9 Johannes Obermayr 2009-10-08 15:26:21 UTC
Created attachment 30190 [details]
Gluon's crash

I have done further tests after my email to mailinglist. I de-/reinstalled firmware and now I can see KDE - but only with artefacts... (all AGP modes)

I think they mostly/mainly happen with some sorts of red and green pixels.

If firmware is not installed the above failure occurs.

Kubrick works. Gluon crashes on closing (attached).

I am not a programmer/developer and so I describe/attach all details of my realizations...
Comment 10 Alex Deucher 2009-10-09 07:21:36 UTC
As mentioned on the mailing list, check your dmesg and make sure the drm is actually loading the firmware.  If you have an initrd, you need to add the firmware to that.
Comment 11 Johannes Obermayr 2009-10-10 08:02:48 UTC
My system works again...

Firmware in initrd was not the problem - it has been loaded since my last post.  Mesa and xf86-video-ati (yesterday checkout) have fixed the problems with gluon and artefacts...

Thanks to all involved.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.