Bug 23793 - OpenOffice and wine cause X hang-ups on radeon X800 XT PE
Summary: OpenOffice and wine cause X hang-ups on radeon X800 XT PE
Status: RESOLVED DUPLICATE of bug 13176
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg 6.7.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2009-09-08 08:32 UTC by 414N
Modified: 2009-09-08 09:49 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Xorg.0.log after hang up (83.72 KB, patch)
2009-09-08 08:32 UTC, 414N
no flags Details | Splinter Review

Description 414N 2009-09-08 08:32:59 UTC
Created attachment 29339 [details] [review]
Xorg.0.log after hang up

I've got an ATI Radeon X800 XT PE on a machine running Slackware64 13.0 (xorg
1.6) using the open-source radeon driver.
I enabled EXA acceleration and everything works quite well (even desktop
compositing effects in KDE 4), except a few things:
- Whenever I run OpenOffice, it hangs the entire X server at the welcome screen
as soon as I push the 'Next' button in order to fill in my personal
information. This happens with compositing effects enabled or disabled, and
even in TWM (so it's not a KDE issue). Tried a few options in xorg.conf and
turning off DRI did the trick. Changing AGPMode to 2 didn't (didn't try 1).
Seems quite strange that OpenOffice makes X hang because of DRI...
After entering my personal information and re-enabling DRI, X hangs as soon as I choose to help or not the development of openoffice.org.
- Some 3D games run through wine (32 bit, with mesa 32 libs installed
correctly) cause the same issue, but not all. Every game I run in SDLMame (3D
or 2D) doesn't hang X.
I can ssh into the the machine through my laptop, in order to see what's
happening (and reboot/halt it, of course). 'top' displays X as a CPU devourer beast.
Looking at Xorg.0.log through my ssh session, I can see a lot of lines like this at the end of the file:

[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnqueue: more than six valuator events; dropping.

Comment 1 Alex Deucher 2009-09-08 08:44:27 UTC
Looks like bug 13176.  Does the patch there in comment 18 help?
Comment 2 414N 2009-09-08 09:40:35 UTC
(In reply to comment #1)
> Looks like bug 13176.  Does the patch there in comment 18 help?

Yes, it helps. I forgot to mention my kernel version before: it is
OpenOffice doesn't hang X anymore, but 3D wine games still cause the problem, this time showing nothing in Xorg.0.log.
Comment 3 Alex Deucher 2009-09-08 09:49:52 UTC

*** This bug has been marked as a duplicate of bug 13176 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.