Bug 23835 - [945] display corrupted with 2048 width
[945] display corrupted with 2048 width
Status: CLOSED DUPLICATE of bug 23718
Product: DRI
Classification: Unclassified
Component: DRM/Intel
unspecified
All Linux (All)
: medium normal
Assigned To: Jesse Barnes
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-10 02:55 UTC by fangxun
Modified: 2012-10-30 05:53 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg log (63.80 KB, text/plain)
2009-09-10 02:55 UTC, fangxun
no flags Details
Dmesg file (46.09 KB, text/plain)
2009-09-10 02:56 UTC, fangxun
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description fangxun 2009-09-10 02:55:47 UTC
Created attachment 29375 [details]
Xorg log

System Environment:
--------------------------
Arch:           i386
Platform:       945GME
Libdrm:         (master)67e4172394a88d4922fb8d9c7c3d96ce7e02c5a6
Mesa:           (mesa_7_6_branch)c6c44bf48124dd5b4661014a8d58482c5a54557f
Xserver:        (server-1.6-branch)3044711412d0a08ba65a491bd2441c0c8980f5e2
Xf86_video_intel:(master)efbcf29dd1a1ca058b7a2a93f0685102c06c9369
Kernel:         (master)e07cccf4046978df10f2e13fe2b99b2f9b3a65db


Bug detailed description:
-------------------------
Start X and setup 2048x768 in dual head: 
   xrandr --output LVDS1 --mode 1024x600
   xrandr --output VGA1 --mode 1024x768
   xrandr --output LVDS1 –left-of VGA1
   Then run "glxgears –geometry 2048x768+0+0", the display get blank. Nothing is drawn and  X process is still active. If pressing "Esc", it would return to xterm from gears process. If run "glxgears –geometry 2047x768+0+0", gears works well in this resolution. This issue also happens on 945GM.


Reproduce steps:
----------------
1. xrandr --output LVDS1 --mode 1024x600
2. xrandr --output VGA1 --mode 1024x768
3. xrandr --output LVDS1 --left-of VGA1
4. glxgears –geometry 2048x768+0+0
Comment 1 fangxun 2009-09-10 02:56:36 UTC
Created attachment 29376 [details]
Dmesg file
Comment 2 Gordon Jin 2009-09-11 00:20:23 UTC
This was reported from moblin: http://bugzilla.moblin.org/show_bug.cgi?id=5658
Comment 3 Ian Romanick 2009-09-22 23:50:00 UTC
I think the following commit may fix this bug.  Please re-test with this patch or later.

commit 972e995b148c220d32f2bf8c0a17c138deec6506
Author: Brian Paul <brianp@vmware.com>
Date:   Mon Sep 21 16:07:14 2009 -0600

    vbo: disable the GL_ARB_draw_elements_base_vertex rebase path
    
    This was introduced with commit 92d7ed8a20d4a018ce5324e6537ae7b478b9e5bf.
    It causes rendering of stray polygons (with sw rendering at least) when
    running the OGL Distilled / Picking demo (click on an object).
    
    This needs additional debugging to fix/restore.
    
    Found one suspect thing: in _tnl_draw_prims() there's some mixed signed/
    unsigned arithmetic/comparing at line 422 that may be incorrect.
Comment 4 fangxun 2009-09-23 19:43:55 UTC
Still fail with the patch.
Comment 5 Li Peng 2009-10-15 23:48:32 UTC
I guess this is H/W related issue, I don't met this problem on 965 H/W. 
not sure if there is some limits on 945.
Comment 6 Li Peng 2009-10-18 23:06:59 UTC
This bug looks like a duplicate of bug 23718
Comment 7 Jesse Barnes 2009-11-20 13:06:43 UTC

*** This bug has been marked as a duplicate of bug 23718 ***