Bug 23884 - Unigine Tropics demo requires float textures
Summary: Unigine Tropics demo requires float textures
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: Other All
: medium enhancement
Assignee: mesa-dev
QA Contact:
URL: http://unigine.com/download/
Whiteboard:
Keywords:
: 27161 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-09-12 09:34 UTC by Sven Arvidsson
Modified: 2011-04-16 06:56 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Arvidsson 2009-09-12 09:34:53 UTC
The Unigine Tropics demo/benchmark requires the GL_ARB_half_float_vertex extension, which Mesa doesn't seem to implement?

 GLRender::require_extension(): required extension GL_ARB_half_float_vertex is not supported
Comment 1 Ian Romanick 2009-09-13 15:13:05 UTC
You are correct.  Mesa does not yet support this extension.  Changing severity to enhancement.
Comment 2 Sven Arvidsson 2009-09-21 05:12:18 UTC
It seems Unigine also requires GL_EXT_framebuffer_multisample 
Comment 3 Sven Arvidsson 2010-01-24 14:37:47 UTC
Now with GL_ARB_half_float_vertex implemented Unigine is one step closer, but it's still not there yet. 

On i965 it complains about missing  GL_EXT_framebuffer_multisample, and in software mode about GL_EXT_texture_filter_anisotropic.
Comment 4 Luca Barbieri 2010-01-24 15:19:21 UTC
There is a patch on the ML that enables GL_EXT_framebuffer_multisample.

What is still missing is floating point texture and render target support, which Unigine does not check for but requires for rendering anything at all.

There are also likely to be serious performance issues on several drivers once it starts working.
Comment 5 Sven Arvidsson 2010-01-26 05:53:22 UTC
GL_EXT_framebuffer_multisample already seems to have been merged, but I guess it's not implemented or possibly not supported by i965?
Comment 6 Roland Scheidegger 2010-01-26 06:01:46 UTC
(In reply to comment #5)
> GL_EXT_framebuffer_multisample already seems to have been merged, but I guess
> it's not implemented or possibly not supported by i965?

i965 can't do multisampling at all.
I haven't looked too closely at the extension, but I think it could probably be supported just like ARB_multisample is - that is, it's pretty much an empty implementation which won't really do anything since there simply are no multi sample buffers available.
Comment 7 Ian Romanick 2010-01-26 10:16:51 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > GL_EXT_framebuffer_multisample already seems to have been merged, but I guess
> > it's not implemented or possibly not supported by i965?
> 
> i965 can't do multisampling at all.
> I haven't looked too closely at the extension, but I think it could probably be
> supported just like ARB_multisample is - that is, it's pretty much an empty
> implementation which won't really do anything since there simply are no multi
> sample buffers available.

Since GL_EXT_framebuffer_multisample is part of GL_ARB_framebuffer_object and i965 supports that, I expect this is probably true.

Comment 8 Gordon Jin 2010-03-18 19:19:36 UTC
*** Bug 27161 has been marked as a duplicate of this bug. ***
Comment 9 Artem S. Tashkinov 2010-03-24 04:37:49 UTC
Unigine Heaven v2.0 demo/benchmark is out and also requires this extension in order to run.
Comment 10 Marek Olšák 2011-03-01 17:10:08 UTC
The float textures are implemented and maintained in this branch:

http://cgit.freedesktop.org/~mareko/mesa/?h=floating2
Comment 11 Md Imam Hossain 2011-03-29 04:06:23 UTC
(In reply to comment #10)
> The float textures are implemented and maintained in this branch:
> 
> http://cgit.freedesktop.org/~mareko/mesa/?h=floating2

Can I have a patch for this, so that I can tryout the demo.
Is it supported on Intel GMA 4500?

Thank you
Comment 12 Artem S. Tashkinov 2011-03-29 04:14:27 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > The float textures are implemented and maintained in this branch:
> > 
> > http://cgit.freedesktop.org/~mareko/mesa/?h=floating2
> 
> Can I have a patch for this, so that I can tryout the demo.
> Is it supported on Intel GMA 4500?
> 
> Thank you

AFAIK Intel Mesa drivers don't yet support float textures, so you are out of luck.
Comment 13 Marek Olšák 2011-03-29 04:25:37 UTC
(In reply to comment #11)
> Is it supported on Intel GMA 4500?

The only driver capable of running Unigine Tropics with the floating2 branch is r300g.
Comment 14 Sven Arvidsson 2011-04-16 06:56:19 UTC
I guess this can be closed now :]


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.