Bug 23916 - D945GCLF2: S-Video output is Black/white while setting PAL format.
Summary: D945GCLF2: S-Video output is Black/white while setting PAL format.
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: ykzhao
QA Contact:
URL:
Whiteboard:
Keywords: patch
Depends on: 22891
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-14 00:01 UTC by Bazin
Modified: 2017-07-24 23:09 UTC (History)
7 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg log with drm.debug=15 (123.37 KB, text/x-log)
2009-09-20 08:30 UTC, Bazin
no flags Details
dmesg log with PAL_D (123.32 KB, text/x-log)
2009-09-20 08:33 UTC, Bazin
no flags Details
dmesg log with PAL_B (123.37 KB, text/x-log)
2009-09-20 12:08 UTC, Bazin
no flags Details
drm.debug=0x4 ( dmesg log) , PAL_D , Kern : 2.6.32-rc2 (121.50 KB, application/octet-stream)
2009-10-10 09:09 UTC, Bazin
no flags Details
drm.debug=0x4 ( dmesg log) , PAL_B , Kern : 2.6.32-rc2 (121.50 KB, application/octet-stream)
2009-10-10 09:11 UTC, Bazin
no flags Details
dmesg log with drm.debug on linux 2.6.32-rc5 PAL_D (89.92 KB, application/octet-stream)
2009-10-25 13:09 UTC, Bazin
no flags Details
dmesg log with drm.debug on linux 2.6.32-rc5 PAL_B (102.57 KB, application/octet-stream)
2009-10-25 13:09 UTC, Bazin
no flags Details
dmesg of PAL_B (123.68 KB, application/octet-stream)
2010-01-18 12:14 UTC, Arnold
no flags Details
dmesg of PAL_D (123.47 KB, application/octet-stream)
2010-01-18 12:15 UTC, Arnold
no flags Details
dmesg with correct kernel (121.36 KB, application/octet-stream)
2010-01-19 10:51 UTC, Arnold
no flags Details
dmesg with correct kernel (120.89 KB, application/octet-stream)
2010-01-19 10:52 UTC, Arnold
no flags Details
dmesg is called 1 second after xrandr (123.92 KB, application/octet-stream)
2010-03-03 12:55 UTC, Arnold
no flags Details
dmesg is called 1 second after xrandr (123.80 KB, application/octet-stream)
2010-03-03 12:56 UTC, Arnold
no flags Details
PAL_B dmesg log on 2.6.33-rc5 (123.62 KB, text/x-log)
2010-03-03 13:23 UTC, Bazin
no flags Details
PAL_D dmesg log on 2.6.33-rc5 (105.79 KB, text/x-log)
2010-03-03 13:26 UTC, Bazin
no flags Details
screen of output in tv time (PAL is set on server and tvtime ) (309.86 KB, image/png)
2010-03-05 11:47 UTC, Bazin
no flags Details
screen of output in tvtime (PAL is set on server and tvtime is set to NTSC ) (271.71 KB, image/png)
2010-03-05 11:48 UTC, Bazin
no flags Details
[Patch 1/2]: fix the type error in setting TV format (1008 bytes, patch)
2010-03-07 22:34 UTC, ykzhao
no flags Details | Splinter Review
[patch 2/2]: obtain the current TV format (3.77 KB, patch)
2010-03-07 22:34 UTC, ykzhao
no flags Details | Splinter Review
dmesg with drm.debug=0x04 (123.89 KB, application/octet-stream)
2010-03-08 13:46 UTC, Arnold
no flags Details
dmesg with drm.debug=0x04 (123.84 KB, application/octet-stream)
2010-03-08 13:46 UTC, Arnold
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bazin 2009-09-14 00:01:29 UTC
I am trying to set PAL_D(B) on S-VIDEO output on intel D945GCLF2  , i used  actual Eric's drm intel (2.6.31-rc9) . 

If i am run "xrandr --output TV1 --set mode PAL_D(B)" , tv blinks , but still is black nad white . 
I added drm.debug=15 .  

Here is kern.log with drm.debug=15 ( is too large ) 

http://www.edisk.cz/stahni/36425/kern.log.tar.gz_10.79MB.html

MD5 : fbc79c8d39e31706ebdb5435b9273d60  kern.log.tar.gz
SHA1 : d7db40f02c3df849162092a83d5ba07311822252  kern.log.tar.gz


Thanks for help .
Comment 1 ykzhao 2009-09-18 01:22:21 UTC
Will you please check whether it can work if you change the mode by using PAL_B mode?
thanks.
Comment 2 Bazin 2009-09-18 08:17:30 UTC
Hi , i try both PAL formats , but not work :( .  
I think  in log is both changes  (NTSC-M -> PAL_D  -> PAL_B ) . 




Comment 3 Bazin 2009-09-20 08:30:48 UTC
Created attachment 29711 [details]
dmesg log with drm.debug=15

Hi , i maked simple script for save log with drm.debug=15 
(
i maked him very simple :  
xrandr --output TV1 --set mode PAL_D(B) 
sleep 1
dmesg > log_file ) 

here is dmesg logf for PAL_B
Comment 4 Bazin 2009-09-20 08:33:07 UTC
Created attachment 29712 [details]
dmesg log with PAL_D
Comment 5 Bazin 2009-09-20 12:08:18 UTC
Created attachment 29713 [details]
dmesg log with PAL_B
Comment 6 ykzhao 2009-10-10 02:01:21 UTC
(In reply to comment #5)
> Created an attachment (id=29713) [details]
> dmesg log with PAL_B 
Sorry for the late response.
Will you please do the test on the latest Eric's drm-intel-next tree and attach the output of dmesg by adding the boot option of "drm.debug=0x4"?
Thanks.
> 

Comment 7 Bazin 2009-10-10 09:07:22 UTC
Hi , i have compiled this kernel : 2.6.32-rc2 #1 SMP Sun Oct 4 . 

i atached dmesg log with  set PAL_D  and PAL_B   . 

Now i downloading   drm-intel from git . After comppiled i post new logs . 
Comment 8 Bazin 2009-10-10 09:09:57 UTC
Created attachment 30253 [details]
drm.debug=0x4 ( dmesg log) , PAL_D , Kern : 2.6.32-rc2
Comment 9 Bazin 2009-10-10 09:11:19 UTC
Created attachment 30254 [details]
drm.debug=0x4 ( dmesg log) , PAL_B , Kern : 2.6.32-rc2
Comment 10 Bazin 2009-10-22 10:27:28 UTC
Hi , any news ? .
Comment 11 Bazin 2009-10-25 13:09:08 UTC
Created attachment 30675 [details]
dmesg log with drm.debug on linux 2.6.32-rc5  PAL_D

Hi all  ,  i compiled new kerne from kernel.org , ( i cant compile kernel form drm-intel-next) . I maked this log with small bash script  
here is : 

#/bin/sh

echo " Set PAL_D "
xrandr  --output TV1 --set mode PAL_D 
sleep 1 
dmesg > PAl_D.log

echo " log saved , now set PAL_B " 
sleep 5 
xrandr --output TV1 --set mode PAL_B
sleep 1
dmesg > PAL_B.log
Comment 12 Bazin 2009-10-25 13:09:49 UTC
Created attachment 30676 [details]
dmesg log with drm.debug on linux 2.6.32-rc5  PAL_B
Comment 13 Arnold 2009-11-08 02:51:25 UTC
Hello,

could you please give a short statement if this is already worked on or if it will be worked on in the near future.

I understand that it is open source and there is no right for a fix but I need to make a decision if I will wait for a fix or switch to a different hardware since the board is currently not usable for me. Does it help to increase the severity?

Please let me know if you need more information for problem determination.

Thanks!!!
Comment 14 Bazin 2009-11-08 05:06:11 UTC
(In reply to comment #13)
> Hello,
> 
> could you please give a short statement if this is already worked on or if it
> will be worked on in the near future.
> 
> I understand that it is open source and there is no right for a fix but I need
> to make a decision if I will wait for a fix or switch to a different hardware
> since the board is currently not usable for me. Does it help to increase the
> severity?
> 
> Please let me know if you need more information for problem determination.
> 
> Thanks!!!
> 



Hi  , i will wait for fix this bug. I can use this board on 99 % (
 s-video not very important ) .  I wana  help with solve this bug , but i dont know how begin ... if u can , giv me more information how i can help . 

Thanks :-) .
Comment 15 Felix 2010-01-05 17:24:37 UTC
For me, the SVideo port was the only reason to buy this board. The fan on the south bridge and the high power consumption is not the reason to buy it. 

The bug is still there, other manufacturers build newer boards with fancy chipsets.

I think I will be happier with a DMI to SVideo converter and a NVIDA Ion board.

Felix
Comment 16 ykzhao 2010-01-15 01:17:41 UTC
Can someone do the test on linux-2.6.33-rc3 kernel and attach the output of dmesg?
Please compile the i915 driver as built-in kernel and add the boot option of "drm.debug=0x06".

Thanks.
Comment 17 Arnold 2010-01-18 12:14:00 UTC
Created attachment 32699 [details]
dmesg of PAL_B
Comment 18 Arnold 2010-01-18 12:15:14 UTC
Created attachment 32700 [details]
dmesg of PAL_D
Comment 19 Arnold 2010-01-18 12:17:38 UTC
I created the log files with kernel 2.6.33-rc3 and xf86-video-intel 2.10.0
Comment 20 Arnold 2010-01-19 10:51:23 UTC
Created attachment 32721 [details]
dmesg with correct kernel
Comment 21 Arnold 2010-01-19 10:52:18 UTC
Created attachment 32722 [details]
dmesg with correct kernel
Comment 22 Arnold 2010-01-19 10:53:28 UTC
I'm sorry, I previously used the wrong kernel. #20 and #21 should be the right logs.
Comment 23 Arnold 2010-02-08 09:34:46 UTC
I increased severity and priority
Comment 24 ykzhao 2010-03-03 00:47:38 UTC
(In reply to comment #23)
> I increased severity and priority
> 
Sorry for the late response.
It seems that the useful info is already flushed. Will you please add the boot option of "drm.debug=0x04" and attach the output of dmesg?

thanks.

Comment 25 Arnold 2010-03-03 12:55:42 UTC
Created attachment 33735 [details]
dmesg is called 1 second after xrandr
Comment 26 Arnold 2010-03-03 12:56:09 UTC
Created attachment 33736 [details]
dmesg is called 1 second after xrandr
Comment 27 Bazin 2010-03-03 13:23:51 UTC
Created attachment 33737 [details]
PAL_B dmesg log on 2.6.33-rc5
Comment 28 Bazin 2010-03-03 13:26:41 UTC
Created attachment 33738 [details]
PAL_D dmesg log on 2.6.33-rc5 

Hi , i maked logs on my actuall kernel ( 2.6.33-rc5) , Logs form new kernel i posted later ( i need to compile  new kernel ).
Comment 29 ykzhao 2010-03-05 00:48:31 UTC
Hi, Bazin/Arnhold
    Sorry for the late response. From the log it seems that the desired TV format is already set after using the following command:
    > xrandr --output TV1 --set mode "PAL_B" (or "PAL_D")
    
    But the TV can't work as expected, right? How about using the "NTSC" format?(For example: NTSC_M, NTSC_J)
    Can you check whether the PAL is supported by the TV monitor?

    I have one D945GCLF2 machine in my hand. Unfortunately I can't reproduce the issue you mentioned.

    Can you describe the problem more clearly? 

thanks
    Yakui
Comment 30 Felix 2010-03-05 02:42:16 UTC
The TV Picture is black/white, no color on any PAL screen.

See
http://ubuntuforums.org/showthread.php?t=993136&page=3
for details.
Comment 31 Arnold 2010-03-05 04:29:44 UTC
yes, it's correct that the picture is black/white on my TV. It's a German TV which only supports PAL signals. Unfortunately I can't test NTSC because my TV does not support it. And yes, according to the verbose option the right mode is set after the xrandr command.
Comment 32 Bazin 2010-03-05 11:39:07 UTC
Hi , i try connect my server to my capture card (VC-100 ) in my desktop (s-video to s-video cable ) and used Tvtime . When i set PAL-B  (in tvtime) i see balack and white and unstable screen . When i switch NTSC (in tvtime ) i see screen good  (good colors and stable ) . .... this i make after restart pc( i not used xrandr ) . after this i switched tv standarn to PAL B  ( on server ) and still see signal in ntsc .. For connect to tv i used s-video to scart cable . 
Comment 33 Bazin 2010-03-05 11:47:04 UTC
Created attachment 33794 [details]
screen of output in tv time (PAL is set on server and tvtime )
Comment 34 Bazin 2010-03-05 11:48:49 UTC
Created attachment 33795 [details]
screen of output in tvtime (PAL is set on server and tvtime is set to NTSC )
Comment 35 nigel 2010-03-06 08:32:36 UTC
(In reply to comment #29)
> Hi, Bazin/Arnhold
>     Sorry for the late response. From the log it seems that the desired TV
> format is already set after using the following command:
>     > xrandr --output TV1 --set mode "PAL_B" (or "PAL_D")
> 
>     But the TV can't work as expected, right? How about using the "NTSC"
> format?(For example: NTSC_M, NTSC_J)
>     Can you check whether the PAL is supported by the TV monitor?
> 
>     I have one D945GCLF2 machine in my hand. Unfortunately I can't reproduce
> the issue you mentioned.
> 
>     Can you describe the problem more clearly? 
> 
> thanks
>     Yakui
> 
Hi
Comment 36 nigel 2010-03-06 08:41:46 UTC
(In reply to comment #29)
> Hi, Bazin/Arnhold
>     Sorry for the late response. From the log it seems that the desired TV
> format is already set after using the following command:
>     > xrandr --output TV1 --set mode "PAL_B" (or "PAL_D")
> 
>     But the TV can't work as expected, right? How about using the "NTSC"
> format?(For example: NTSC_M, NTSC_J)
>     Can you check whether the PAL is supported by the TV monitor?
> 
>     I have one D945GCLF2 machine in my hand. Unfortunately I can't reproduce
> the issue you mentioned.
> 
>     Can you describe the problem more clearly? 
> 
> thanks
>     Yakui
> 

Hi, I have a D945GCLF2 and am hoping that this problem can be sorted. My experience is that when you use xrandr to change format, the s-video output blanks for a moment and then returns in the same format. Xrandr however states that the format has changed. I have a multisync monitor that can handle NTSC, but when I try the different NTSC formats, the monitor reports that the format is still the same. It looks to me that the video format does not change.  Hope this helps.  Nigel
Comment 37 ykzhao 2010-03-07 22:34:19 UTC
Created attachment 33849 [details] [review]
[Patch 1/2]: fix the type error in setting TV format
Comment 38 ykzhao 2010-03-07 22:34:47 UTC
Created attachment 33850 [details] [review]
[patch 2/2]: obtain the current TV format
Comment 39 ykzhao 2010-03-07 22:36:22 UTC
Can someone try the two debug patches in comment #37/38 on 2.6.33 kernel and attach the output of dmesg?

Thanks.
Comment 40 ykzhao 2010-03-07 22:47:33 UTC
(In reply to comment #34)
> Created an attachment (id=33795) [details]
> screen of output in tvtime (PAL is set on server and tvtime is set to NTSC ) 
> 
HI, Bazin
    Thanks for the attached screenshot. It seems that the TV monitor can't work normally if the PAL mode is used by SDVO-TV card and TV monitor. If the TV monitor still uses the NTSC mode, it can work well.
     How about the following two cases?
         a. TV monitor is always set in NTSC mode. Can the TV monitor work well by changing the TV format by using the command of xrandr? (For example: PAL, SECAM_*)
         b. Can the TV monitor work well if the s-video output and TV monitor use the NTSC format?

     
     It will be great if you can try the debug patches in comment #37/38 and attach the output of dmesg.

Thanks.

Comment 41 ykzhao 2010-03-07 22:57:32 UTC
(In reply to comment #31)
> yes, it's correct that the picture is black/white on my TV. It's a German TV
> which only supports PAL signals. Unfortunately I can't test NTSC because my TV
> does not support it. And yes, according to the verbose option the right mode is
> set after the xrandr command.

Hi, Arnold
   Can the tv monitor work well if the s-video output uses the default TV format?(It means that you don't change the TV format by using the command of xrandr).
   Does your tv monitor have an opportunity to work well when you change the all available TV format by using the command of xrandr? 

Thanks
    Yakui
> 

Comment 42 ykzhao 2010-03-07 23:27:11 UTC

> Hi, I have a D945GCLF2 and am hoping that this problem can be sorted. My
> experience is that when you use xrandr to change format, the s-video output
> blanks for a moment and then returns in the same format. Xrandr however states
> that the format has changed. I have a multisync monitor that can handle NTSC,
> but when I try the different NTSC formats, the monitor reports that the format
> is still the same. It looks to me that the video format does not change.  Hope
> this helps.  Nigel

Hi, Nigel
    Thanks for the detailed description. And your description is helpful to understand the issue of this bug.
 
For the SDVO-TV card: it seems that the SDVO-TV card contains one TV encoder, which can be configured by selecting one TV format to generate the expected TV format signal. When the external TV monitor can accept the input video format signal, it will work well. But whether it can report the video format depends on the configuration of TV monitor. 

But it is very interesting that Bazin's TV monitor can't work well if the TV monitor uses the PAL format as the s-video output card.

thanks.
    Yakui 

Comment 43 nigel 2010-03-08 10:52:37 UTC
(In reply to comment #42)

Hi, re Bazin's monitor - when I use my PAL based system (which is why I would like this issue resolved) I  get a Black / White image which is missing the lower part of the screen.
My multisync monitor is capable of syncing to NTSC, PAL and SECAM and will output to the screen the format of the video input. Regardless of which format I set using xrandr, the monitor always reports an input format of N358 which I think is standard format of NTSC used in USA.
Regards

Nigel 

Comment 44 Bazin 2010-03-08 11:55:16 UTC
Hi . i have pal (only)  based TV , i only tested connect  s-vidoe output to my tv capture card (Winfaast VC-100) . 

Btw i compiled new kernel (2.2.33) with patches and s-video otput works nice :-)  tv screen is colored  :-) :-) . Thanks much 
Comment 45 Bazin 2010-03-08 11:57:11 UTC
sorry  i think 2.6.33 kernel no 2.2.XX :-) 
Comment 46 Arnold 2010-03-08 13:35:06 UTC
(In reply to comment #41)
> (In reply to comment #31)
> > yes, it's correct that the picture is black/white on my TV. It's a German TV
> > which only supports PAL signals. Unfortunately I can't test NTSC because my TV
> > does not support it. And yes, according to the verbose option the right mode is
> > set after the xrandr command.
> 
> Hi, Arnold
>    Can the tv monitor work well if the s-video output uses the default TV
> format?(It means that you don't change the TV format by using the command of
> xrandr).
>    Does your tv monitor have an opportunity to work well when you change the
> all available TV format by using the command of xrandr? 
> 
> Thanks
>     Yakui
> > 
> 

Hi Yakui,

the standard mode on my system is NTSC_M. The picture is fine but it is black/white. I tried all available PAL modes but never got a colored picture.

Thanks

Arnold
Comment 47 Arnold 2010-03-08 13:39:59 UTC
(In reply to comment #39)
> Can someone try the two debug patches in comment #37/38 on 2.6.33 kernel and
> attach the output of dmesg?
> 
> Thanks.
> 

I compiled kernel 2.6.33 with the two patches. The dmesg output will be in the next comments. xrandr --verbose shows that PAL_D/PAL_B is set, but the picture is still black/white
Comment 48 Arnold 2010-03-08 13:46:10 UTC
Created attachment 33867 [details]
dmesg with drm.debug=0x04
Comment 49 Arnold 2010-03-08 13:46:29 UTC
Created attachment 33868 [details]
dmesg with drm.debug=0x04
Comment 50 Bazin 2010-03-08 14:14:55 UTC
(In reply to comment #47)
> (In reply to comment #39)
> > Can someone try the two debug patches in comment #37/38 on 2.6.33 kernel and
> > attach the output of dmesg?
> > 
> > Thanks.
> > 
> 
> I compiled kernel 2.6.33 with the two patches. The dmesg output will be in the
> next comments. xrandr --verbose shows that PAL_D/PAL_B is set, but the picture
> is still black/white
> 

If u use S-Video to S-scart cable , u need to join 15 and  20 pin in scart  . Much tv not suport S-video over scart .  
Comment 51 ykzhao 2010-03-08 17:10:10 UTC
(In reply to comment #44)
> Hi . i have pal (only)  based TV , i only tested connect  s-vidoe output to my
> tv capture card (Winfaast VC-100) . 
> 
> Btw i compiled new kernel (2.2.33) with patches and s-video otput works nice
> :-)  tv screen is colored  :-) :-) . Thanks much 

Hi, Bazin
    Thanks for the testing. 
    Do you mean that S-video output can work well after applying the two patches on 2.6.33 kernel? Have you tried the PAL mode on the server/TV monitor?

    How about the issue if you don't apply the two patches on 2.6.33 kernel?

Thanks.
   Yakui
> 

Comment 52 ykzhao 2010-03-08 17:14:12 UTC
(In reply to comment #43)
> (In reply to comment #42)
> 
> Hi, re Bazin's monitor - when I use my PAL based system (which is why I would
> like this issue resolved) I  get a Black / White image which is missing the
> lower part of the screen.

Can you monitor work well if you try the different TV format by using the command of xrandr?

> My multisync monitor is capable of syncing to NTSC, PAL and SECAM and will
> output to the screen the format of the video input. Regardless of which format
> I set using xrandr, the monitor always reports an input format of N358 which I
> think is standard format of NTSC used in USA.
> Regards
> 
> Nigel 
> 

Comment 53 Bazin 2010-03-08 21:39:05 UTC
(In reply to comment #51)
> (In reply to comment #44)
> > Hi . i have pal (only)  based TV , i only tested connect  s-vidoe output to my
> > tv capture card (Winfaast VC-100) . 
> > 
> > Btw i compiled new kernel (2.2.33) with patches and s-video otput works nice
> > :-)  tv screen is colored  :-) :-) . Thanks much 
> 
> Hi, Bazin
>     Thanks for the testing. 
>     Do you mean that S-video output can work well after applying the two
> patches on 2.6.33 kernel? Have you tried the PAL mode on the server/TV monitor?

  Yes i appplying two patches . If change format i see in dmesg  "112.150057] Intel_SDVO Current TV format is PAL_D" 
> 
>     How about the issue if you don't apply the two patches on 2.6.33 kernel?
> 
> Thanks.
>    Yakui
> > 
> 

Comment 54 ykzhao 2010-03-08 23:52:22 UTC
> > Hi, Bazin
> >     Thanks for the testing. 
> >     Do you mean that S-video output can work well after applying the two
> > patches on 2.6.33 kernel? Have you tried the PAL mode on the server/TV monitor?
> 
>   Yes i appplying two patches . If change format i see in dmesg  "112.150057]
> Intel_SDVO Current TV format is PAL_D" 

Hi, Bazin

Does the "Yes i appplying two patches" means that the TV can work well after applying the patches?(The TV format for server and TV monitor is PAL)

The "Intel_SDVO Current TV format is PAL_D" in dmesg is the debug info. It only reports the current TV format in course of modesetting/getting modes. In fact it doesn't update/configure the TV format. The patch in comment #37 fixes the incorrect parameter in course of changing TV format.

Do you have an opportunity to try the only patch in comment #37 and see whether it can work well?

Thanks.

> > 
> >     How about the issue if you don't apply the two patches on 2.6.33 kernel?
> > 
> > Thanks.
> >    Yakui
> > > 
> > 
> 

Comment 55 nigel 2010-03-09 05:44:22 UTC
(In reply to comment #52)
> (In reply to comment #43)
> > (In reply to comment #42)
> > 
> > Hi, re Bazin's monitor - when I use my PAL based system (which is why I would
> > like this issue resolved) I  get a Black / White image which is missing the
> > lower part of the screen.
> 
> Can you monitor work well if you try the different TV format by using the
> command of xrandr?
I have applied the patch in comment #37 and Yes !! I can now switch between formats and get the correct colours and lines. 
I applied the patch to kernel 2.6.33-rc8 - I downloaded the source from www.kernel.org. I am using intel 2.9.0 from the Ubuntu Karmic repository. 
When I boot up the system, the video format is always ntsc, but I can change it using xrandr.
The only other minor difference is the PAL image is offset to the right of the screen when compared to the NTSC image.

Thank you for the fix

Regards

Nigel  

Comment 56 Arnold 2010-03-09 12:54:06 UTC
(In reply to comment #50)
> (In reply to comment #47)
> > (In reply to comment #39)
> > > Can someone try the two debug patches in comment #37/38 on 2.6.33 kernel and
> > > attach the output of dmesg?
> > > 
> > > Thanks.
> > > 
> > 
> > I compiled kernel 2.6.33 with the two patches. The dmesg output will be in the
> > next comments. xrandr --verbose shows that PAL_D/PAL_B is set, but the picture
> > is still black/white
> > 
> 
> If u use S-Video to S-scart cable , u need to join 15 and  20 pin in scart  .
> Much tv not suport S-video over scart .  
> 

Y I P P E E !!!!!!

it works!!!!! There must be different s-video signals. My DVD player works very well with the regular s-video to scart adapter. But anyway with the hint of Bazin also my Intel board is working correctly now and I'm happy.

Thank you all!!!

Arnold
Comment 57 ykzhao 2010-03-09 18:09:41 UTC
> > 
> 
> Y I P P E E !!!!!!
> 
> it works!!!!! There must be different s-video signals. My DVD player works very
> well with the regular s-video to scart adapter. But anyway with the hint of
> Bazin also my Intel board is working correctly now and I'm happy.

It is good news that the s-video can work well after using the s-video to scart adaptor.
Can you help me confirm whether the s-video can work well with/without the patch in comment #37?

Thanks
    Yakui
> 
> Thank you all!!!
> 
> Arnold
> 

Comment 58 ykzhao 2010-03-09 18:22:30 UTC
> > Can you monitor work well if you try the different TV format by using the
> > command of xrandr?
> I have applied the patch in comment #37 and Yes !! I can now switch between
> formats and get the correct colours and lines. 

Hi, Nigel
    It is good news that your TV monitor also can work well after applying the patch. And the TV monitor can't work well without the patch in comment #37, Right?

> I applied the patch to kernel 2.6.33-rc8 - I downloaded the source from
> www.kernel.org. I am using intel 2.9.0 from the Ubuntu Karmic repository. 
> When I boot up the system, the video format is always ntsc, but I can change it
> using xrandr.
> The only other minor difference is the PAL image is offset to the right of the
> screen when compared to the NTSC image.

This different is related with another TV characteristics(left/right margin). Can you try the property of left/right margin to see whether the position of PAL image can be adjusted to the position as NTSC image?

Thanks
    Yakui
> 
> Thank you for the fix
> 
> Regards
> 
> Nigel  
> 

Comment 59 nigel 2010-03-10 00:08:39 UTC
(In reply to comment #58)

> Hi, Nigel
>     It is good news that your TV monitor also can work well after applying the
> patch. And the TV monitor can't work well without the patch in comment #37,
> Right?
> 
 
Hi

Right, the patch is required for my TV monitor to work well.


Thank you again for the fix, as a bonus, is it possible to change the default to PAL so that my system will boot up with the correct video format ?

Regards

Nigel
Comment 60 Arnold 2010-03-10 12:41:39 UTC
(In reply to comment #57)
> > > 
> > 
> > Y I P P E E !!!!!!
> > 
> > it works!!!!! There must be different s-video signals. My DVD player works very
> > well with the regular s-video to scart adapter. But anyway with the hint of
> > Bazin also my Intel board is working correctly now and I'm happy.
> 
> It is good news that the s-video can work well after using the s-video to scart
> adaptor.
> Can you help me confirm whether the s-video can work well with/without the
> patch in comment #37?
> 
> Thanks
>     Yakui
> > 
> > Thank you all!!!
> > 
> > Arnold
> > 
> 
I only get a colored picture with the patch. With kernel 2.6.33 only the picture is black/white.
Comment 61 ykzhao 2010-03-10 18:29:29 UTC
Now the corresponding patch is already sent to intel-gfx mailing list. And we will have to wait for some time before it can be picked up.
   >http://lists.freedesktop.org/archives/intel-gfx/2010-March/006188.html

BTW: The above patch has dependency on another patch set. And it can't be applied on 2.6.32/2.6.33 kernel directly.

Hi, Bazin/Arnold/Nigel
    Thanks for your help and testing. 

Thanks.
Comment 62 ykzhao 2010-03-11 00:51:47 UTC
As the corresponding patch is already sent to the intel-gfx mailing list and we have to wait for some time before it is picked up, this priority of this will be downgraded.

Thanks.
Comment 63 Wang Zhenyu 2010-04-19 01:31:43 UTC
Patch on 'drm-intel-next' branch now.

drm/i915: Fix the incorrect argument for SDVO SET_TV_format command

Otherwise it will cause that S-video output becomes black/white when
switching to other TV format.

http://bugs.freedesktop.org/show_bug.cgi?id=23916

Signed-off-by: Zhao Yakui <yakui.zhao@intel.com>
Tested-by: Arnold <arnold.erbsloeh@web.de>
Tested-by: Bazin <bazin.cz@gmail.com>
Tested-by: Nigel <nigel_tuck@eircom.net>
Signed-off-by: Zhenyu Wang <zhenyuw@linux.intel.com>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.