Bug 23933 - Use some more TLS/SSL conditions (revoked, insecure, limit exceeded)
Summary: Use some more TLS/SSL conditions (revoked, insecure, limit exceeded)
Status: NEW
Alias: None
Product: Telepathy
Classification: Unclassified
Component: gabble (show other bugs)
Version: unspecified
Hardware: All All
: low enhancement
Assignee: Telepathy bugs list
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords:
Depends on: 29461
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-14 09:32 UTC by Guillaume Desmottes
Modified: 2010-08-09 11:00 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume Desmottes 2009-09-14 09:32:40 UTC
Once bug #23931 has been fixed and the new errors are available in a released tp-glib, we should use them in Gable.

+++ This bug was initially created as a clone of Bug #23931 +++

There are three more specific TLS/SSL errors that were covered by the 
generic "other errors" case before:

* revoked (certificate in CRL or cancelled via OCSP or other mechanism)
* insecure (broken algorithm (eg MD2) or otherwise cryptographically weak)
* limit exceeded (certificate parameters large enough to indicate DOS attempt, or
  TLS/SSL implementation does not support sufficiently large parameter range)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.