Bug 23980 - [KMS] [RS780] Not loading firmware/kernel panic
[KMS] [RS780] Not loading firmware/kernel panic
Status: RESOLVED WORKSFORME
Product: DRI
Classification: Unclassified
Component: DRM/Radeon
DRI git
x86-64 (AMD64) Linux (All)
: medium major
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-16 16:03 UTC by ojab
Modified: 2009-09-27 12:58 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
kernel log with panic (45.10 KB, patch)
2009-09-16 16:03 UTC, ojab
no flags Details | Splinter Review
kernel log with oops (4.91 KB, patch)
2009-09-16 16:04 UTC, ojab
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description ojab 2009-09-16 16:03:57 UTC
Created attachment 29608 [details] [review]
kernel log with panic

`modprobe radeon modeset=1` spontaneously not loading firmware (firmware loading works ok. because sometimes it loads just fine and KMS is working).
Sometimes module loading leads to kernel oops, simple test `while true; do modprobe radeon modeset=1; rmmod radeon; done` leads to kernel panic/oops.
kernel from airlied git, drm-next branch 8dfaa8a7779ad2667d539aca6ae11cd87f562db6
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon HD 3300 Graphics
Comment 1 ojab 2009-09-16 16:04:23 UTC
Created attachment 29609 [details] [review]
kernel log with oops
Comment 2 Michel Dänzer 2009-09-17 01:08:42 UTC
> `modprobe radeon modeset=1` spontaneously not loading firmware (firmware
> loading works ok. because sometimes it loads just fine and KMS is working).

Sounds like an issue with the firmware loading code then, not with the DRM.
Comment 3 ojab 2009-09-27 12:58:09 UTC
Cannot reproduce with linux-2.6 master after drm-next merge.