Bug 24167 - latest X server crash with radeon driber in KMS mode only
latest X server crash with radeon driber in KMS mode only
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Server/Acceleration/EXA
git
x86 (IA32) Linux (All)
: medium normal
Assigned To: Xorg Project Team
Xorg Project Team
:
: 24177 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-26 07:39 UTC by Andrew Randrianasulu
Modified: 2009-09-26 17:38 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
gdb log (4.06 KB, text/plain)
2009-09-26 07:39 UTC, Andrew Randrianasulu
no flags Details
xorg.conf (10.43 KB, text/plain)
2009-09-26 07:42 UTC, Andrew Randrianasulu
no flags Details
X log (old) (22.19 KB, text/plain)
2009-09-26 07:42 UTC, Andrew Randrianasulu
no flags Details
Possible fix (2.39 KB, patch)
2009-09-26 16:26 UTC, Michel Dänzer
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Randrianasulu 2009-09-26 07:39:38 UTC
Created attachment 29860 [details]
gdb log

I have X server from git master c9ec2bab2f258798fd6e6676698c732f09571a60 (dmx: undefine MITSHM, move undefs to miinitext.c.) and xf86-video-ati from git up to 3efecebb10de7f7bacf9f8c57ae20fd508097294 ( radeon: fix vline handling for kms)

When i try to start X server, it gives me backtrace.

Disabling UploadToScreen in xorg.conf doesn't help
Comment 1 Andrew Randrianasulu 2009-09-26 07:42:10 UTC
Created attachment 29861 [details]
xorg.conf
Comment 2 Andrew Randrianasulu 2009-09-26 07:42:58 UTC
Created attachment 29862 [details]
X log (old)
Comment 3 Michel Dänzer 2009-09-26 16:26:06 UTC
Created attachment 29871 [details] [review]
Possible fix

Does this patch fix the crash with no UploadToScreen hook?

Note that I don't think it can be the same problem when there's an UploadToScreen hook. If it still crashes in that case, please open another report for that with a corresponding backtrace.
Comment 4 Andrew Randrianasulu 2009-09-26 16:41:27 UTC

(In reply to comment #3)
> Created an attachment (id=29871) [details]
> Possible fix
> 
> Does this patch fix the crash with no UploadToScreen hook?
> 
> Note that I don't think it can be the same problem when there's an
> UploadToScreen hook. If it still crashes in that case, please open another
> report for that with a corresponding backtrace.
> 

Yes, this patch fixed my crash. Strangely, for both non-UploadToScreen and UTS (default) cases. Thanks!
Comment 5 Michel Dänzer 2009-09-26 17:13:55 UTC
Please don't resolve bugs before the fix is applied (which it is now, and nominated on http://wiki.x.org/wiki/Server17Branch), thanks.
Comment 6 demon 2009-09-26 17:38:30 UTC
*** Bug 24177 has been marked as a duplicate of this bug. ***