Bug 24189 - dependency resolution failed error ... ok ... dependency resolution failed error ... ok
Summary: dependency resolution failed error ... ok ... dependency resolution failed er...
Status: RESOLVED NOTABUG
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: low trivial
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-27 20:15 UTC by Denny Crane
Modified: 2018-08-21 15:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denny Crane 2009-09-27 20:15:51 UTC
PackageKit 0.4.9-1
gnome-packagekit 2.27.3-1
Fedora 11

Attempted to install a single update which was left over from a previous update (since the dependency resolution failed) ... as could be expected, I received a dependency resolution error, but upon clicking ok, it acts like it's starting over or something and then comes back with the same exact error (same detailed info too). I reproduced this error several times over the course of a day or two.
Comment 1 Richard Hughes 2009-09-28 07:54:05 UTC
Yes, I think I've already fixed that bug. Is there any way you can test the rawhide rpm in F11, and if that works I'll work on backporting the new code. I'm sortof busy myself with all the F12 stuff. Thanks.
Comment 2 Denny Crane 2009-09-28 08:01:18 UTC
(In reply to comment #1)
> Yes, I think I've already fixed that bug. Is there any way you can test the
> rawhide rpm in F11, and if that works I'll work on backporting the new code.
> I'm sortof busy myself with all the F12 stuff. Thanks.
> 

Yeah, I'll test that tonight.

Nate
Comment 3 Denny Crane 2009-09-28 16:21:16 UTC
PackageKit 0.5.3-0.1.20090921git
gnome-packagekit 2.28.0-1

I tested the rawhide versions of PackageKit and gnome-packagekit on Fedora 11, but it seems that this minor bug may have turned into a major one? ... Instead of displaying a duplicate error dialog, it seems that the newer version (at least as run on F11) simply cancels the entire update and does not let the user continue at all.

I tested as follows:
1) Started with Fedora 11 with all current updates as of yesterday or the day before; enabled rawhide.
2) Installed the versions of PackageKit and gnome-packagekit noted above, along with 5 other PackageKit-___ files and 197 updates it required.
3) Left the rawhide repository active (particularly because the "Software Sources" link disappeared from the menus).
4) Did a "Software Update" which returned a list of hundreds of packages
5) "totem = 2.26.3 is needed by package totem-gstreamer-2.26.3-3.fc11.i586"
6) "Close"
7) "Software Update" window remains and gives no indication of attempting to complete the task. I am able to click "Install Updates" to reproduce the same result.
Comment 4 Richard Hughes 2018-08-21 15:52:58 UTC
We moved the upstream bugtracker to GitHub a long time ago. If this issue still affects you please re-create the issue here: https://github.com/hughsie/PackageKit/issues
 
Sorry for the impersonal message, and fingers crossed your issue no longer happens. Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.