Bug 24210 - Xserver doesn't start with G45 chipset
Summary: Xserver doesn't start with G45 chipset
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Wang Zhenyu
QA Contact: Xorg Project Team
Depends on:
Reported: 2009-09-29 04:39 UTC by arne
Modified: 2009-10-14 07:00 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

X log (14.78 KB, text/plain)
2009-09-29 09:32 UTC, arne
no flags Details

Description arne 2009-09-29 04:39:31 UTC
I've tried to install Archlinux with the mainboard Gigabyte GA-EG45M-UD2H. It has a Intel G45 chipset and Intel GMA 4500HD graphics onboard. The only working driver is Vesa. With Intel driver gdm won't start.
Comment 1 Julien Cristau 2009-09-29 06:07:08 UTC
if this is with server 1.6.4, see bug 24200.
Comment 2 Julien Cristau 2009-09-29 06:07:38 UTC
(In reply to comment #1)
> if this is with server 1.6.4, see bug 24200.
and if not, please attach the full X log.
Comment 3 arne 2009-09-29 08:35:30 UTC
It is server, working on the log.
Comment 4 arne 2009-09-29 09:32:53 UTC
Created attachment 29948 [details]
X log
Comment 5 Wang Zhenyu 2009-10-13 22:34:07 UTC
Would you be able to start X in gdb to get the backtrace? This looks like an issue on 64-bit system?
Comment 6 arne 2009-10-14 00:55:00 UTC
I've tried several distros(ubuntu,debian,fedora,archlinux) 32-bit and 64-bit and none could use the intel-driver, only vesa. i'm working on a gdb backtrace.
Comment 7 arne 2009-10-14 07:00:59 UTC
Sorry to have you bothered, the beta of Ubuntu 9.10 works, so I guess it's no bug.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.