Bug 24351 - Firewire hard drive is considered system-internal
Firewire hard drive is considered system-internal
Status: RESOLVED FIXED
Product: udisks
Classification: Unclassified
Component: detection
unspecified
All All
: medium normal
Assigned To: David Zeuthen (not reading bugmail)
https://launchpad.net/bugs/442604
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-06 11:55 UTC by Martin Pitt
Modified: 2009-10-09 07:34 UTC (History)
0 users

See Also:


Attachments
Patch (1.26 KB, patch)
2009-10-06 11:59 UTC, Martin Pitt
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Pitt 2009-10-06 11:55:34 UTC
Firewire hard drives are detected as system internal:

added:     /org/freedesktop/DeviceKit/Disks/devices/sdd
Showing information for /org/freedesktop/DeviceKit/Disks/devices/sdd
  native-path:                 /sys/devices/pci0000:00/0000:00:06.0/0000:01:06.0/fw-host0/0050770e00000e0d/0050770e00000e0d-0/host9/target9:0:0/9:0:0:0/block/sdd
  device:                      8:48
  device-file:                 /dev/sdd
    by-id:                     /dev/disk/by-id/ieee1394-0050770e00000e0d:0:0
    by-path:                   /dev/disk/by-path/pci-0000:01:06.0-ieee1394-0x0050770e00000e0d:0:0
  detected at:                 dim. 04 oct. 2009 23:33:05 CEST
  system internal:             1
  removable:                   0

This is because dk-disks only checks for subsystem=="firewire". However, current kernel calls that "ieee1394".
Comment 1 Martin Pitt 2009-10-06 11:59:01 UTC
Created attachment 30116 [details] [review]
Patch

I had the reporter test a package with this patch, and he confirmed that automounting now works fine.

In case you are interested, http://launchpadlibrarian.net/33131716/sys.txt.gz is a sysfs dump. The linked Ubuntu bug also has udev and dk-disks monitor log, etc.
Comment 2 Martin Pitt 2009-10-06 12:00:32 UTC
Oh, I kept "firewire" because hal does the same, it seems safe to do so, and older/future kernels might have actually called it "firewire".
Comment 3 David Zeuthen (not reading bugmail) 2009-10-09 07:31:02 UTC
(In reply to comment #2)
> Oh, I kept "firewire" because hal does the same, it seems safe to do so, and
> older/future kernels might have actually called it "firewire".

Oh, you guys are still shipping the old firewire stack? ;-)

Anyway, committed, thanks.
Comment 4 Martin Pitt 2009-10-09 07:34:22 UTC
> Oh, you guys are still shipping the old firewire stack? ;-)

We don't, but who knows when they decide to rename it back to "firewire" (which is admittedly much more readable than ieee1943, erm, 1349, erm, 1394, erm "the old iPod connector" :)