Bug 24364 - Need a default Appearance of Annotation.
Summary: Need a default Appearance of Annotation.
Status: RESOLVED DUPLICATE of bug 23108
Alias: None
Product: poppler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-06 19:11 UTC by Bug Fly
Modified: 2009-10-07 00:38 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
text annotation without appearance. (61.65 KB, application/octet-stream)
2009-10-06 19:11 UTC, Bug Fly
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bug Fly 2009-10-06 19:11:37 UTC
Created attachment 30132 [details]
text annotation without appearance.

According to PDF spec. 12.5.5, there should be a default Appearance to display when no appearance stream are supplied.

poppler don't display anything when not appearance found. The attached pdf file has a text annotation without a Appearnace (AP) at the lower half of the first page. In Acrobat Reader, it shows a white sticky note and popup a window to show its contents when clicked. In evince, no trace of the text annotation can be spotted.

see also: https://bugzilla.gnome.org/show_bug.cgi?id=168304#c17
Comment 1 Bug Fly 2009-10-06 19:47:11 UTC
Also according to "12.5.6.4 Text Annotations", The /Name entry of Text Annotation should has some predefined icons to use and the "Note" is the default name:

   Key  Type   Value
   =============================================================================
   Name name   (Optional) The name of an icon that shall be used in displaying
	       the annotation. Conforming readers shall provide predefined icon
	       appearances for at least the following standard names: 

	           Comment, Key, Note, Help, NewParagraph, Paragraph, Insert
		   
	       Additional names may be supported as well. Default value: Note.

	       The annotation dictionary's AP entry, if present, shall take
	       precedence over the Name entry; see Table 168 and 12.5.5,
	       "Appearance Streams."
   
Comment 2 Carlos Garcia Campos 2009-10-07 00:38:25 UTC
Thanks for the bug report, this is a duplicate of bug #23108


*** This bug has been marked as a duplicate of bug 23108 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.