Bug 24556 - (Yohan) Xorg running very high cpu utilization and freezing
(Yohan)
Xorg running very high cpu utilization and freezing
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/intel
unspecified
x86-64 (AMD64) Linux (All)
: medium major
Assigned To: Wang Zhenyu
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-15 10:31 UTC by yohan.bataille
Modified: 2010-02-21 20:59 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
sysprof log (422.75 KB, application/x-gzip)
2009-10-15 10:31 UTC, yohan.bataille
no flags Details
Xorg.0.log (97.25 KB, application/x-gzip)
2009-10-15 10:32 UTC, yohan.bataille
no flags Details
lspci -vv (23.63 KB, text/plain)
2009-10-15 10:33 UTC, yohan.bataille
no flags Details
dmesg (36.41 KB, text/plain)
2009-10-15 10:33 UTC, yohan.bataille
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description yohan.bataille 2009-10-15 10:31:52 UTC
Created attachment 30455 [details]
sysprof log

Nom           : xorg-x11-server-Xorg
Architecture  : x86_64
Version       : 1.7.0
Révision      : 1.fc12

Nom           : xorg-x11-drv-intel
Architecture  : x86_64
Version       : 2.9.0
Révision      : 2.fc12

$ uname -r
2.6.31.1-56.fc12.x86_64

$ cat /etc/fedora-release
Fedora release 11.92 (Rawhide)

Hi,
Xorg is very sluggish on my intel X4500HD graphic card.
It's sluggish even in GDM at startup but it's worse when using firefox : it's getting slower and slower until X seems to be freezed and hard reboot is needed.
The uncompressed Xorg log weights 15M. sysprof points to drm_do_probe_ddc_edid.
I don't have a Xorg.conf and i don't use composition.
Comment 1 yohan.bataille 2009-10-15 10:32:53 UTC
Created attachment 30456 [details]
Xorg.0.log
Comment 2 yohan.bataille 2009-10-15 10:33:27 UTC
Created attachment 30457 [details]
lspci -vv
Comment 3 yohan.bataille 2009-10-15 10:33:51 UTC
Created attachment 30458 [details]
dmesg
Comment 4 Eric Anholt 2009-10-19 11:31:51 UTC
The usual failure causing this is a hotplug interrupt getting stuck so the desktop keeps getting told that things have changed, then it asks what's changed, and getting the answer is expensive.

Also, could you try linus master kernel?  There have been some fixes in the hotplug area there.
Comment 5 yohan.bataille 2009-10-23 10:09:57 UTC
I can't reproduce this bug anymore with kernel 2.6.31.5-91.rc1.fc12.x86_64.
Comment 6 Danny Yee 2010-02-12 16:25:53 UTC
I still have this problem with the latest Fedora 12 kernel - 2.6.31.12-174.2.3.fc12.i686.PAE.  This is also with an X4500 graphics card.

I've reduced the incidence of the problem using "nomodeset" in the kernel boot options and 
  Option      "AccelMethod" "EXA"
in the Device section of xorg.conf.

But every so often when under stress X still slows to a crawl.

Killing udevd is a fix, but an ugly one.
Comment 7 Wang Zhenyu 2010-02-21 20:59:55 UTC
yohan has reported this is fixed for him, pls open new bug for your problem which may be different.