Bug 24564 - prpl-qq's default protocol version (QQ2005) doesn't work
prpl-qq's default protocol version (QQ2005) doesn't work
Status: RESOLVED NOTOURBUG
Product: Telepathy
Classification: Unclassified
Component: haze
unspecified
x86 (IA32) Linux (All)
: medium normal
Assigned To: Telepathy bugs list
Telepathy bugs list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-15 16:50 UTC by Allan Andersen
Modified: 2009-10-23 02:20 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Allan Andersen 2009-10-15 16:50:45 UTC
Hi

I'm new user to Empathy (Gnome IM program) and have trouble setting up my QQ account.
Naturally I filed a bug report at the Gnome bug page, but got advised to report the problem here. When logging on I get"Authentication Failed".

My account information are correct and I can log-on without any problems if
using Eva or using the official QQ client on my Windows XP.

I'm using default settings as shown below:
Server - Auto
Client Version - qq2005
Use TCP - Yes
Show Notice - Yes
Show News - Yes
Show Chat - Yes
Keep Alive Interval - 60
Update Interval - 300

Empathy log these information:
empathy/Account-FEJLFIND: 1,255650e+09: enable_or_disable_account: Account 859821182 is now enabled
empathy/Account-FEJLFIND: 1,255650e+09: _empathy_account_set_connection: Readying connection for /org/freedesktop/Telepathy/Account/haze/qq/_38598211820
empathy/Account-FEJLFIND: 1,255650e+09: emp_account_connection_cb: Signalling connection (nil) of account /org/freedesktop/Telepathy/Account/haze/qq/_38598211820
empathy/Account-FEJLFIND: 1,255650e+09: _empathy_account_connection_invalidated_cb: (/org/freedesktop/Telepathy/Account/haze/qq/_38598211820) Connection invalidated
empathy/Account-FEJLFIND: 1,255650e+09: emp_account_connection_cb: Signalling connection (nil) of account /org/freedesktop/Telepathy/Account/haze/qq/_38598211820
empathy/Account-FEJLFIND: 1,255650e+09: empathy_account_connection_ready_cb: (/org/freedesktop/Telepathy/Account/haze/qq/_38598211820) Connection failed to become ready: Unknown disconnection reason
empathy/Account-FEJLFIND: 1,255650e+09: emp_account_connection_cb: Signalling connection (nil) of account /org/freedesktop/Telepathy/Account/haze/qq/_38598211820
empathy/Account-FEJLFIND: 1,255650e+09: accounts_dialog_destroy_cb: 0x871b8c8
--- END ---

I'm using Ubuntu 9.10 and Gnome 2.28.0. The Gnome bug ID is 598046 which now is in state resolved as not Gnome issue.

Let me know if futher information is required. I've search the bug list for similar errors without finding similar error but is sorry if such already have been created.
Comment 1 Will Thompson 2009-10-20 09:54:39 UTC
(In reply to comment #0)
> Client Version - qq2005

Try changing this to 'QQ2008'. If that works, I'll make it the libpurple default.
Comment 2 Allan Andersen 2009-10-20 18:05:52 UTC
Thanks for the suggestion. I'll try it when I get back from work later today.
Comment 3 Allan Andersen 2009-10-21 05:42:10 UTC
How simple it some times can be :-)
Changing 'Client Version' to qq2008 solved the problem.

Thanks a lot, so nice to have it all protocols in just one program now. I'm not sure if I'm supposed to resolve this?
Comment 4 Will Thompson 2009-10-21 09:42:57 UTC
Closing as NOTOURBUG. I've pinged the Pidgin list about this; see <http://pidgin.im/pipermail/devel/2009-October/008966.html> for why I didn't just change the default in libpurple.
Comment 5 Allan Andersen 2009-10-22 06:22:46 UTC
There was a major update and at least Empathy was upgraded. I also think telepathy-haze was upgraded too.

Empathy is now 2.28.1 and telepathy-haze is 0.3.2-1. QQ client version is of course kept as qq2008.

This is shown in the log:
859821182 is now disabled
empathy/Account-FEJLFIND: 1,256217e+09: enable_or_disable_account: Account 859821182 is now enabled
empathy/Account-FEJLFIND: 1,256217e+09: _empathy_account_set_connection: Readying connection for /org/freedesktop/Telepathy/Account/haze/qq/_38598211820
empathy/Account-FEJLFIND: 1,256217e+09: emp_account_connection_cb: Signalling connection (nil) of account /org/freedesktop/Telepathy/Account/haze/qq/_38598211820
empathy/Account-FEJLFIND: 1,256217e+09: accounts_dialog_destroy_cb: 0x9d81118
empathy/Other-FEJLFIND: 1,256217e+09: user_data_destroyed_cb: user_data for 0x9e45a80 destroyed; disconnecting
empathy/Other-FEJLFIND: 1,256217e+09: user_data_destroyed_cb: user_data for 0x9e44d50 destroyed; disconnecting
empathy/Other-FEJLFIND: 1,256217e+09: user_data_destroyed_cb: user_data for 0x9e44bb0 destroyed; disconnecting
empathy/Other-FEJLFIND: 1,256217e+09: user_data_destroyed_cb: user_data for 0x9e43db0 destroyed; disconnecting
empathy/Other-FEJLFIND: 1,256217e+09: user_data_destroyed_cb: user_data for 0x9e44d10 destroyed; disconnecting
empathy/Other-FEJLFIND: 1,256217e+09: user_data_destroyed_cb: user_data for 0x9e44bc0 destroyed; disconnecting
empathy/Other-FEJLFIND: 1,256217e+09: user_data_destroyed_cb: user_data for 0x9e44c30 destroyed; disconnecting
empathy/Account-FEJLFIND: 1,256217e+09: _empathy_account_connection_invalidated_cb: (/org/freedesktop/Telepathy/Account/haze/qq/_38598211820) Connection invalidated
empathy/Account-FEJLFIND: 1,256217e+09: emp_account_connection_cb: Signalling connection (nil) of account /org/freedesktop/Telepathy/Account/haze/qq/_38598211820
empathy/Account-FEJLFIND: 1,256217e+09: empathy_account_connection_ready_cb: (/org/freedesktop/Telepathy/Account/haze/qq/_38598211820) Connection failed to become ready: Unknown disconnection reason
empathy/Account-FEJLFIND: 1,256217e+09: emp_account_connection_cb: Signalling connection (nil) of account /org/freedesktop/Telepathy/Account/haze/qq/_38598211820
empathy/Other-FEJLFIND: 1,256217e+09: debug_window_get_messages_cb: GetMessages failed: Method "GetMessages" with signature "" on interface "org.freedesktop.Telepathy.Debug" doesn't exist
empathy/Other-FEJLFIND: 1,256217e+09: debug_window_get_messages_cb: GetMessages failed: Method "GetMessages" with signature "" on interface "org.freedesktop.Telepathy.Debug" doesn't exist
Comment 6 Will Thompson 2009-10-22 07:01:29 UTC
Please get debugging output from Haze as per <http://telepathy.freedesktop.org/wiki/Debugging>.
Comment 7 Allan Andersen 2009-10-22 18:30:46 UTC
Think maybe problem is caused by new security test started by QQ one of these days?
This morning when I would logon to QQ on my XP I got a security warning where and answering some questions on a page was required. On my Ubuntu I didn't see this security warning, but as I now have passed it on XP it will might work again using Empathty.

Anyway I'll test it later today and report back how it goes. If not I'll of course use the page you mentions for debugging.
Comment 8 Allan Andersen 2009-10-23 00:58:59 UTC
Looks like it was the security warning causing the problem so no problem to login at all :-)

Thanks a lot for your time. I've selected the same closure code (Closing as NOTOURBUG) as you used earlier.
Comment 9 Will Thompson 2009-10-23 02:20:24 UTC
(In reply to comment #8)
> Looks like it was the security warning causing the problem so no problem to
> login at all :-)

FWIW, in reply to my mail to the Pidgin list about this, khc warned of exactly this kind of problem with QQ2008: <http://pidgin.im/pipermail/devel/2009-October/008973.html>.