Bug 24572 - Can't compile git drm/linux-core/drm_memory.c
Summary: Can't compile git drm/linux-core/drm_memory.c
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/other (show other bugs)
Version: DRI git
Hardware: x86 (IA32) Linux (All)
: high blocker
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-16 08:50 UTC by Dario
Modified: 2019-10-14 13:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dario 2009-10-16 08:50:57 UTC
Hi all, i must compile from git to get the mach64 drm module, but compiling in kernel 2.6.31 i got the error:
  CC [M]  /usr/src/drm/drm/linux-core/drm_memory.o                                                     
/usr/src/drm/drm/linux-core/drm_memory.c: In function 'agp_remap':                                     
/usr/src/drm/drm/linux-core/drm_memory.c:286: error: 'struct agp_memory' has no member named 'memory'  
make[2]: *** [/usr/src/drm/drm/linux-core/drm_memory.o] Error 1
make[1]: *** [_module_/usr/src/drm/drm/linux-core] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.31'
make: *** [modules] Error 2

How to fix this?
10x
Comment 1 samit vats 2009-11-08 23:02:42 UTC
(In reply to comment #0)
> Hi all, i must compile from git to get the mach64 drm module, but compiling in
> kernel 2.6.31 i got the error:
>   CC [M]  /usr/src/drm/drm/linux-core/drm_memory.o                              
> /usr/src/drm/drm/linux-core/drm_memory.c: In function 'agp_remap':              
> /usr/src/drm/drm/linux-core/drm_memory.c:286: error: 'struct agp_memory' has no
> member named 'memory'  
> make[2]: *** [/usr/src/drm/drm/linux-core/drm_memory.o] Error 1
> make[1]: *** [_module_/usr/src/drm/drm/linux-core] Error 2
> make[1]: Leaving directory `/usr/src/linux-2.6.31'
> make: *** [modules] Error 2
> 
> How to fix this?
> 10x
> 


struct agp_memory now uses 'pages' not 'memory' in 2.6.31. need to update the following files  to reflect this change

linux-core/drm_agpsupport.c
linux-core/drm_memory.c
linux-core/drm_vm.c
Comment 2 Dario 2009-11-09 01:45:50 UTC
(In reply to comment #1)
> 
> struct agp_memory now uses 'pages' not 'memory' in 2.6.31. need to update the
> following files  to reflect this change
> 
> linux-core/drm_agpsupport.c
> linux-core/drm_memory.c
> linux-core/drm_vm.c
> 

Yes... I read something about this on different forum... but how change this files? :)
Other people (dev?) how build on 2.6.31? ^_^"
Why don't commit the change on repository? This wasn't only my problem, I think.

10x
Comment 3 Dario 2009-12-14 06:00:41 UTC
Ok... now the source code was cutted out from git... exist anymore? where can i find the drm code (kernel various .ko driver)?

thanks
Comment 4 Alex Deucher 2009-12-14 06:12:24 UTC
(In reply to comment #3)
> Ok... now the source code was cutted out from git... exist anymore? where can i
> find the drm code (kernel various .ko driver)?

In the kernel source.
Comment 5 Dario 2009-12-14 06:58:33 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Ok... now the source code was cutted out from git... exist anymore? where can i
> > find the drm code (kernel various .ko driver)?
> 
> In the kernel source.
> 

;)

 /drivers/gpu/drm/ 

ok, so I can say definitively 'good bye' to mach64 driver? no more (poor) hw acceleration... :/
sad
Comment 6 Martin Peres 2019-10-14 13:20:19 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.