Bug 24701 - Bitmap fonts don't look as good as xpdf / adobe reader
Summary: Bitmap fonts don't look as good as xpdf / adobe reader
Status: RESOLVED DUPLICATE of bug 5589
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-23 10:03 UTC by Keith Curtis
Modified: 2010-01-26 10:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
poppler rendering (81.10 KB, image/png)
2009-10-23 10:12 UTC, Keith Curtis
Details
xpdf renderer (147.31 KB, image/png)
2009-10-23 10:13 UTC, Keith Curtis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Curtis 2009-10-23 10:03:14 UTC
I was going to read this book:
http://mises.org/etexts/bureaucracy.pdf

But trying to read it on screen is very difficult because it is a bitmap font and looks terrible. 

I opened it in xpdf and adobe reader it looks much better.
Comment 1 Albert Astals Cid 2009-10-23 10:07:53 UTC
Can you add screenshots of what you get with the three readers, please?
Comment 2 Keith Curtis 2009-10-23 10:12:30 UTC
Created attachment 30642 [details]
poppler rendering

default renderer
Comment 3 Keith Curtis 2009-10-23 10:13:03 UTC
Created attachment 30643 [details]
xpdf renderer

xpdf renderer
Comment 4 Keith Curtis 2009-10-23 10:15:19 UTC
I added the default Ubuntu renderer and the xpdf renderer. 

I didn't include a screenshot of the adobe reader because it looks just like the xpdf.
Comment 5 Albert Astals Cid 2009-10-23 10:23:03 UTC
Seems it's a cairo backend problem, at least i can see a very noticeable different between splash and cairo rendering here
Comment 6 Keith Curtis 2009-10-23 10:30:48 UTC
Note: the differences may seem subtle but they are not. I tried reading several pages and I got tired because I had to spend my energy just decoding the letters rather than focusing on the words.
Comment 7 Carlos Garcia Campos 2010-01-26 10:39:50 UTC
It works for me now, it looks like a duplicate of bug #5589. 

*** This bug has been marked as a duplicate of bug 5589 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.