Bug 2473 - dlopen: [...]libglx.so: undefined symbol: glSamplePatternSGIS
Summary: dlopen: [...]libglx.so: undefined symbol: glSamplePatternSGIS
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/DDX/Xorg/dlloader (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Adam Jackson
QA Contact:
Depends on:
Reported: 2005-02-05 09:22 UTC by Diego Calleja
Modified: 2005-02-06 22:51 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

xorg log (39.20 KB, text/plain)
2005-02-05 09:25 UTC, Diego Calleja
no flags Details

Description Diego Calleja 2005-02-05 09:22:50 UTC
I have the following output in cvs HEAD (as of Sat Feb  5 17:20:16 UTC 2005):
(II) Loading /opt/xorg/lib/modules/extensions/libglx.so
dlopen: /opt/xorg/lib/modules/extensions/libglx.so: undefined symbol:
(EE) Failed to load /opt/xorg/lib/modules/extensions/libglx.so

hardware is a p3, via82c686 chipset and ATI radeon 9200 se agp card running
debian sarge with 2.6.11-rc3-mm1 kernel.

X.org startup log attache
Comment 1 Diego Calleja 2005-02-05 09:25:08 UTC
Created attachment 1835 [details]
xorg log
Comment 2 Adam Jackson 2005-02-07 10:02:26 UTC
take the Load "GLcore" line out of your xorg.conf and try again.
Comment 3 Diego Calleja 2005-02-07 12:35:57 UTC
Still it fails:

(II) Loading /opt/xorg/lib/modules/extensions/libglx.so
dlopen: /opt/xorg/lib/modules/extensions/libglx.so: undefined symbol: glSamplePa
(EE) Failed to load /opt/xorg/lib/modules/extensions/libglx.so
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (loader failed, 7)

glxinfo also complains about not finding GLX extension

My section "Modules" is:
Section "Module"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "record"
        Load    "speedo"
        Load    "type1"
        Load    "vbe"
Comment 4 Diego Calleja 2005-02-07 17:51:12 UTC
Ok, I have been building xorg cvs for a while and always used "make Everything".
I suspected imake may be doing ugly things and it turned out I was right - doing
make clean and doing a make World solved the error. Yet another proof that imake
sucks ;)

Now I get the following running glxinfo:
diego@estel ~ # LIBGL_DEBUG=verbose glxinfo
name of display: :0.0
libGL: XF86DRIGetClientDriverName: 5.0.1 r200 (screen 0)
libGL: OpenDriver: trying /opt/xorg/lib/modules/dri/r200_dri.so
drmOpenByBusid: Searching for BusID pci:0000:01:00.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: drmOpenMinor returns 4
drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
libGL error: 
R200 DRI driver expected DDX version 4.0.x but got version 5.0.1
libGL warning: 3D driver returned no fbconfigs.
libGL error: InitDriver failed
libGL error: reverting to (slow) indirect rendering

No old versions of anything are involved:
diego@estel ~ # ldd /opt/xorg/bin/glxinfo  
        libGLU.so.1 => /opt/xorg/lib/libGLU.so.1 (0xb7ead000)
        libGL.so.1 => /opt/xorg/lib/libGL.so.1 (0xb7e40000)
        libXext.so.6 => /opt/xorg/lib/libXext.so.6 (0xb7e32000)
        libX11.so.6 => /opt/xorg/lib/libX11.so.6 (0xb7d67000)
        libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7d57000)
        libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7d35000)
        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7c01000)
        libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0xb7b46000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x4265e000)
        libXxf86vm.so.1 => /opt/xorg/lib/libXxf86vm.so.1 (0xb7b41000)
        libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7b3e000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0xb7f3a000)

Everything worked OK in the past. I guess I will close this bug report and will
submit the new one in a new entry.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.