Bug 24793 - pkcon won't recognize package names with version numbers included
Summary: pkcon won't recognize package names with version numbers included
Status: RESOLVED NOTABUG
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-29 12:18 UTC by Jens Knutson
Modified: 2018-08-21 15:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Knutson 2009-10-29 12:18:27 UTC
When removing packages (or installing or anything else, for that matter), pkcon refuses to recognize any package with a version name attached, e.g.:
"docbook-style-dsssl-1.79-8.fc12.noarch"  or  "docbook-style-dsssl-1.79-8" are not recognized as valid package names.

Yum, on the other hand, supports this just fine.


Why anyone would care:
It's a PITA to copy & paste/pipe things from yum.log to select packages one wants to remove
Comment 1 Jens Knutson 2009-10-29 14:07:02 UTC
I appear to be mistaken.  I could have sworn that Yum used to handle this, but I just tried it again now, and it failed... strange!

If this is one of those "unfixable" cases due to the nature of rpm naming standards or whatever, feel free to close this.  Otherwise maybe it could live on as an enhancement request?
Comment 2 Richard Hughes 2018-08-21 15:52:24 UTC
We moved the upstream bugtracker to GitHub a long time ago. If this issue still affects you please re-create the issue here: https://github.com/hughsie/PackageKit/issues
 
Sorry for the impersonal message, and fingers crossed your issue no longer happens. Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.