Bug 24834 - configure.ac blocks updates of libpng
configure.ac blocks updates of libpng
Status: RESOLVED FIXED
Product: cairo
Classification: Unclassified
Component: general
1.8.8
All All
: high blocker
Assigned To: Carl Worth
cairo-bugs mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-01 00:12 UTC by John Bowler
Modified: 2009-11-01 07:44 UTC (History)
2 users (show)

See Also:


Attachments
Stop cairo requiring specific versions of libpng (1.16 KB, patch)
2009-11-01 00:12 UTC, John Bowler
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description John Bowler 2009-11-01 00:12:40 UTC
Created attachment 30874 [details] [review]
Stop cairo requiring specific versions of libpng

Cairo configure.ac specifically detects libpng versions, thus attempts to release new versions of libpng (post 1.2) are foiled by the failure of cairo to even configure.

The attached file fixes the problem.

1.4.0 has been tested against cairo and compiles correctly.
Comment 1 M Joonas Pihlaja 2009-11-01 02:04:41 UTC
This has been fixed in cairo master in commit

http://cgit.freedesktop.org/cairo/commit/?id=d544828934e479071fe5246fc0bdbbad33c097e8

If you can check whether the fix works for you that would be great, and if it doesn't please provide some OS info in your bug report.  If it does we can push the fix into the 1.8 branch for the next stable update.
Comment 2 John Bowler 2009-11-01 03:33:53 UTC
(In reply to comment #1)
> http://cgit.freedesktop.org/cairo/commit/?id=d544828934e479071fe5246fc0bdbbad33c097e8

I tested it (the commit diff) and it worked.  I applied it to configure, not configure.ac, as gentoo loads a distribution package (the source with autogen.sh already run).  The result did, indeed, find libpng14

Anyway by visual examination it will be equivalent to my version.

You can repro anywhere by installing libpng-1.4.0beta88 (or, probably, any 1.4.0 beta) and *removing* any older libpng libraries.  If you don't remove the libraries (the normal situation) the problem is undetectable because configure finds the old library but then the build uses the new, 1.4, png.h header (and the new library.)
Comment 3 M Joonas Pihlaja 2009-11-01 07:44:16 UTC
Cherry-picked and pushed to the 1.8 branch, so it'll be fixed in 1.8.10 when that's released.  Cheers.

http://cgit.freedesktop.org/cairo/commit/?h=1.8&id=0a5ec9802a39dee240a1a3476af1ef8a7db9b6b3