Bug 24874 - Hostname mismatch error message is a tad unhelpful
Summary: Hostname mismatch error message is a tad unhelpful
Status: NEW
Alias: None
Product: Wocky
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium minor
Assignee: Sjoerd Simons
QA Contact:
Depends on:
Reported: 2009-11-03 06:39 UTC by Will Thompson
Modified: 2009-11-03 06:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Will Thompson 2009-11-03 06:39:03 UTC
I tried to connect to an XMPP server, and was rewarded by a certificate mismatch error. Telepathy doesn't provide any way for the CM to tell higher levels what exactly the mismatch was, but I thought "hey, I'll look at the debug output". The debug output told me: "SSL Certificate does not match name 'server.i.was.connecting.to'". Loudmouth's error message included the name on the certificate as well, which would have been useful.

wocky_tls_session_verify_peer() would need to grow a way to return extra miscellaneous information about the certificate it checked for this to be fixed.

(I tried to connect with Loudmouth but it fell down a well during starttls, so Wocky still came out ahead. :))

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.