Bug 24928 - [945gm] Display is intermittently filled with single colour
[945gm] Display is intermittently filled with single colour
Status: RESOLVED DUPLICATE of bug 24314
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
7.5
Other All
: medium normal
Assigned To: Jesse Barnes
:
: 25964 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-04 13:31 UTC by Priit Laes (irc: plaes)
Modified: 2010-02-05 01:42 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
photo of screen showing corruption (233.12 KB, image/jpeg)
2009-11-08 10:07 UTC, Priit Laes (irc: plaes)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Priit Laes (irc: plaes) 2009-11-04 13:31:38 UTC
x11-libs/libdrm-2.4.15 
media-libs/mesa-7.5.2 
x11-base/xorg-server-1.7.1 
x11-drivers/xf86-video-intel-2.9.1 

(--) PCI:*(0:0:2:0) 8086:27a2:17aa:201a Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller rev 3, Mem @ 0xee100000/524288, 0xd0000000/268435456, 0xee200000/262144, I/O @ 0x00001800/8

During regular computer use (web browsing, vim in console, compiling stuff) screen gets intermittently filled with single colour and stays like that. Not even VT-switching helps.

Everything else seems to be working fine behind this "colourful blanket" as I am able to switch to console, blindly log in as root and type `pm-suspend` :) Resuming from suspend fortunately fixes the display.

Also, this seems to be a regression after upgrading from 2.8.x to 2.9.[01].
Comment 1 Priit Laes (irc: plaes) 2009-11-08 01:06:40 UTC
Few more things about this issue:
1) One things that seems to be causing the total blackout is when a browser (Webkit-gtk+epiphany) is loading image and displaying it while it loads (I think it is called sequential loading - ie you can see how new lines appear on image)

2) Sometimes when I compile something and there's lots of traffic in terminal (gnome-terminal), some parts of the display shift a bit or just go black (I don't remember seeing any other colours). This corruption is cleared when I either press alt+tab or switch to another workspace.
Comment 2 Priit Laes (irc: plaes) 2009-11-08 01:09:13 UTC
And I have also dumped GPU contents from few blackouts (don't remember the exact colour, though..)

http://plaes.org/files/2009-Q4/blank-screen-gpu-dump
http://plaes.org/files/2009-Q4/blank-screen-gpu-dump-v2

These are ~month old... if needed I could create some newer ones ;)
Comment 3 Priit Laes (irc: plaes) 2009-11-08 10:07:55 UTC
Created attachment 31048 [details]
photo of screen showing corruption

The bottom part of the screen is blacked out, and part of the middle screen is switched left (also left side of the terminal is visible on the right side of the screen)

There's also slight corruption on the titlebar of the browser on the background.
Comment 4 Jesse Barnes 2009-11-20 14:06:57 UTC
What kernel are you using?  Linus's tree has some fixes for the flicker...
Comment 5 Priit Laes (irc: plaes) 2009-11-21 01:54:45 UTC
Currently 2.6.32-rc5-00053-gd995053, but will try a newer one...
Comment 6 Priit Laes (irc: plaes) 2009-11-21 02:56:31 UTC
Pulled latest kernel and had no luck reproducing these issues :(

\o/

I will reopen the bug when I run into this issue again :)

Comment 7 Priit Laes (irc: plaes) 2009-11-22 01:56:03 UTC
The major issue - screen gets filled with single colour, still occurs with latest kernel. 

Fortunately I haven't yet noticed screen corruption.
Comment 8 Priit Laes (irc: plaes) 2009-11-25 13:42:35 UTC
This was still happening under mesa-7.6.

I also tried to watch a movie today on this laptop and during first 10 minutes of watching I had  to go through 3 or 4 suspend cycles :S

Any ideas how to debug it?
Comment 9 Priit Laes (irc: plaes) 2009-11-28 14:35:20 UTC
Tried testing with external monitor.

It seems that external monitor (VGA1) is not affected by this issue.

I connected external display after I had got a blank screen and this was working fine. I even tried switching back and forth between the displays with Fn+F7 key (this is Lenovo X60s laptop).

Next I tried watching some movies on external display (usually this triggers the screen blanking quite easily), but forunately had no success...

So this issue apparently affects only internal screen (LVDS1).
Comment 10 Priit Laes (irc: plaes) 2009-12-23 00:42:04 UTC
I tried updating the whole stack, but this is still happening:

x11-libs/libdrm-2.4.17 
media-libs/mesa-7.7 
x11-base/xorg-server-1.7.3.901-r1 
x11-drivers/xf86-video-intel-2.9.1 
kernel 2.6.33-rc1-00154-gf7b84a6
Comment 11 Priit Laes (irc: plaes) 2009-12-23 01:08:40 UTC
Things work fine with kernel 2.6.31-rc5-00470-g85dfd81, so I assume this is actually problem with kernel bits.
Comment 12 Priit Laes (irc: plaes) 2009-12-23 14:04:08 UTC
No more issues since 2.6.33-rc1-00266-gf42ecb2 :)
Comment 13 Priit Laes (irc: plaes) 2009-12-24 00:53:53 UTC
(In reply to comment #12)
> No more issues since 2.6.33-rc1-00266-gf42ecb2 :)
> 

I was a bit too hasty here. Apparently everything works fine until first suspend.

After resume, I can notice flicker and these spurious screen blankings.
Comment 14 Julien Cristau 2009-12-24 03:42:24 UTC
> --- Comment #13 from Priit Laes (irc: plaes) <plaes@plaes.org>  2009-12-24 00:53:53 PST ---
> I was a bit too hasty here. Apparently everything works fine until first
> suspend.
> 
> After resume, I can notice flicker and these spurious screen blankings.
> 
I'm told this might be fixed by the following commit in Eric's tree:

commit cf74ecbbff3e3b45bae61d28d2220f74d853e2f0
Author: Jesse Barnes <jbarnes@virtuousgeek.org>
Date:   Thu Dec 17 11:11:13 2009 -0800

    drm/i915: remove render reclock support

Didn't have time to test myself yet though...  Hopefully that will be
backported to 2.6.32.x at some point.
Comment 15 Priit Laes (irc: plaes) 2009-12-24 11:49:40 UTC
(In reply to comment #14)
> > --- Comment #13 from Priit Laes (irc: plaes) <plaes@plaes.org>  2009-12-24 00:53:53 PST ---
> > I was a bit too hasty here. Apparently everything works fine until first
> > suspend.
> > 
> > After resume, I can notice flicker and these spurious screen blankings.
> > 
> I'm told this might be fixed by the following commit in Eric's tree:
> 
> commit cf74ecbbff3e3b45bae61d28d2220f74d853e2f0
> Author: Jesse Barnes <jbarnes@virtuousgeek.org>
> Date:   Thu Dec 17 11:11:13 2009 -0800
> 
>     drm/i915: remove render reclock support
> 
> Didn't have time to test myself yet though...  Hopefully that will be
> backported to 2.6.32.x at some point.
> 

I tried this patch out, but this doesn't fix this issue :(
Comment 16 Andrej Gelenberg 2010-01-09 09:41:45 UTC
have same issue.
Comment 17 Andrej Gelenberg 2010-01-09 09:45:31 UTC
*** Bug 25964 has been marked as a duplicate of this bug. ***
Comment 18 Priit Laes (irc: plaes) 2010-01-20 10:08:13 UTC
As pointed out by jcristau:
Adding i915.powersave=0 works around this issue.

Comment 19 Priit Laes (irc: plaes) 2010-02-05 01:42:06 UTC

*** This bug has been marked as a duplicate of bug 24314 ***