Bug 2498 - x11-drm-20050104 borks on xorg startup
Summary: x11-drm-20050104 borks on xorg startup
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/other (show other bugs)
Version: XOrg git
Hardware: Other Linux (All)
: high major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-08 09:57 UTC by Marcin Kurek
Modified: 2005-10-27 06:38 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg configuration file (3.17 KB, text/plain)
2005-02-08 10:07 UTC, Marcin Kurek
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Kurek 2005-02-08 09:57:22 UTC
Some time ago I decide to give a try to recent snapshot of DRM modules in my 
Gentoo installation. Generaly I was able to emerge and compile it without any 
problems, but on first startup of Xorg (6.8.1.904) I get only a weird crash with 
following message in log's:

--------
Jan 22 23:47:31 pegasos kernel: radeon: Ignoring new-style parameters in 
presence of obsolete ones
Jan 22 23:47:31 pegasos kernel: [drm] Initialized radeon 1.13.0 20041207 on 
minor 0: ATI Technologies Inc Radeon RV250 If [Radeon 9000]
Jan 22 23:47:31 pegasos kernel: [drm] Used old pci detect: framebuffer loaded
Jan 22 23:47:42 pegasos kernel: Oops: kernel access of bad area, sig: 11 [#1]
Jan 22 23:47:42 pegasos kernel: NIP: E2378438 LR: E23785D8 SP: CCAA9E40 REGS: 
ccaa9d90 TRAP: 0300    Not tainted
Jan 22 23:47:42 pegasos kernel: MSR: 00009032 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 11
Jan 22 23:47:42 pegasos kernel: DAR: 0000003C, DSISR: 40000000
Jan 22 23:47:42 pegasos kernel: TASK = df0be720[21951] 'X' THREAD: ccaa8000
Jan 22 23:47:42 pegasos kernel: Last syscall: 54
Jan 22 23:47:42 pegasos kernel: GPR00: E2495000 CCAA9E40 DF0BE720 E2D80000 
E2F7F000 DC24FEE0 00306400 00800000
Jan 22 23:47:42 pegasos kernel: GPR08: C4000000 E2300000 00000000 D49EE300 
88042444 102047D0 101A0000 101A0000
Jan 22 23:47:42 pegasos kernel: GPR16: 101A0000 10200000 10200000 107D5C4C 
7FFFF5E4 00000007 7FFFF170 DF681230
Jan 22 23:47:42 pegasos kernel: GPR24: D6F57180 E2390000 E2390000 CCAA9E50 
D49EE2A0 D49EE300 D6913000 DFB4E000
Jan 22 23:47:42 pegasos kernel: NIP [e2378438] radeon_cp_init+0x614/0x960 
[radeon]
Jan 22 23:47:42 pegasos kernel: LR [e23785d8] radeon_cp_init+0x7b4/0x960 
[radeon]
Jan 22 23:47:42 pegasos kernel: Call trace:
Jan 22 23:47:42 pegasos kernel: [e237178c] radeon_ioctl+0x194/0x1cc [radeon]
Jan 22 23:47:42 pegasos kernel: [c006ce24] sys_ioctl+0x2fc/0x498
Jan 22 23:47:42 pegasos kernel: [c0004400] ret_from_syscall+0x0/0x44
========

I am using the 2.6.10 kernel with following GFX card on my machine:

0001:01:08.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 If 
[Radeon 9000] (rev 01) (prog-if 00 [VGA])
        Subsystem: Hightech Information System Ltd. RV250 If [Excalibur Radeon 
9000]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping+ SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 0 (2000ns min)
        Interrupt: pin A routed to IRQ 9
        Region 0: Memory at c0000000 (32-bit, prefetchable)
        Region 1: I/O ports at ffff1000 [size=256]
        Region 2: Memory at c4000000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [58] AGP version 2.0
                Status: RQ=48 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 
64bit- FW+ AGP3- Rate=x1,x2
                Command: RQ=1 ArqSz=0 Cal=0 SBA+ AGP- GART64- 64bit- FW- 
Rate=<none>
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,
D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

The machine is a Pegasos2 computer with PPC CPU (1GHz G4)

I did some research to help resolve this problem ...

1) I can load the readeon module using modprobe command without any crash or 
something. It's loaded normaly. It seems starting Xorg cause this crash.

2) I can avoid this message by removing dri extension from Xorg configuration 
file. This means the problem is related to DRM module.

3) If I remove the BusType "PCI" option from Xorg configuration file I can load 
the X without this error (But without DRI too because there is no working 
AGPGart for this machine and Xorg disables DRI because of that in that case)

4) Not only I have some problems with this version of DRM. One of the Gentoo 
users reported a similar problem to my one (weird errors when loading Xorg but 
he can use DRI in the end, I mean no crash on his system) He is using Pegasos2 
machine too but with R9200SE card.

drm] Initialized radeon 1.13.0 20041207 on minor 0: ATI Technologies Inc RV280 
[Radeon 9200 SE]
[drm] Used old pci detect: framebuffer loaded
[drm] Loading R200 Microcode
[drm:radeon_ati_pcigart_cleanup] *ERROR* no scatter/gather memory!
[drm:radeon_do_cleanup_cp] *ERROR* failed to cleanup PCI GART!

More log's and configuration files for both cases (My one and the 9200SE) can be 
found at http://bugs.gentoo.org/show_bug.cgi?id=79146

I can attach them here too if someone want me to.
Comment 1 Marcin Kurek 2005-02-08 10:07:16 UTC
Created attachment 1865 [details]
Xorg configuration file

I forgot to attach Xorg configuration file
Comment 2 Shawn Starr 2005-10-27 21:23:45 UTC
Reporter: Have you tried this with drm 1.19.0 20050911? Radeon 9600 works very
good for me. Lots of changes have been done since 1.13.0 20041207 drm.
Comment 3 Marcin Kurek 2005-10-27 23:38:51 UTC
Ahhh :) I completly forgot about that. Works fine now with CVS snap of DRM.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.