Bug 2503 - demos/terrain is broken
Summary: demos/terrain is broken
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-08 14:04 UTC by Roland Scheidegger
Modified: 2011-03-01 12:39 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Scheidegger 2005-02-08 14:04:54 UTC
terrain looks like it's divided up in "3 moving parts" (just start it and you'll
see what I mean), but only if you look forward, if you turn 90 degrees to the
right or left it seems ok. Happens with r200 dri, LIBGL_ALWAYS_INDIRECT=1 set
and the sw-only libGL.
At least I don't think it looked like that in the past, maybe some recent tnl
changes broke it?
Comment 1 Keith Whitwell 2005-02-08 15:10:22 UTC
It's always had some discontinuities between the strips.   I can confirm that
these are also visible running on nvidia hardware.

Leaving the bug open as it would be nice to get the demo fixed.
Comment 2 Kevin DeKorte 2008-04-15 08:35:07 UTC
On the intel driver I also see this segmentation using git master of drm, mesa and xf76-drv-intel and xserver as of 4/15/2008
I do not recall seeing this with Mesa in fedora 8
Comment 3 Adam Jackson 2009-08-24 12:23:02 UTC
Mass version move, cvs -> git
Comment 4 Marek Olšák 2011-03-01 12:39:14 UTC
I can see nothing wrong with the demo, it appears to be fixed. I have tested r300g, swrast, and softpipe. Closing..


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.