Bug 25086 - [855] Fujistu Siemens Amilo M7400 : Freeze shortly after X startup
Summary: [855] Fujistu Siemens Amilo M7400 : Freeze shortly after X startup
Status: RESOLVED DUPLICATE of bug 27187
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Carl Worth
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-13 21:13 UTC by Geir Ove Myhr
Modified: 2010-07-17 07:35 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Batchbuffer dump & logs with DebugFlushCaches option (230.32 KB, application/x-compressed-tar)
2009-11-13 21:13 UTC, Geir Ove Myhr
no flags Details
Xorg.0.log (33.71 KB, text/plain)
2009-11-13 21:14 UTC, Geir Ove Myhr
no flags Details
Output of dmesg (40.92 KB, text/plain)
2009-11-13 21:14 UTC, Geir Ove Myhr
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Geir Ove Myhr 2009-11-13 21:13:20 UTC
Created attachment 31192 [details]
Batchbuffer dump & logs with DebugFlushCaches option

Forwarding a 855GM freeze bug with batchbuffer dumps from ubuntu user Pierre Monlong:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/477972

This bug may or may not be a duplicate of bug 24789, but I thought I'd report it here since it contains a fresh batchbuffer dump with updated driver and DebugFlushCaches option set.

[Problem]
Xorg freezes (GPU hangs) shortly after Xorg startup.

[Original report]
Binary package hint: xserver-xorg-video-intel

Since i've upgraded from 9.04 to 9.10 : The X server freezes shortly after it is started, no matter what I do. Usually this happens at the login procedure when i need to tape my password, or later when a use the System>Preferences menu in gnome desktop.
Mouse pointer remains functional (but clicking is not functionnal)

Very very close to this bug : https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/447892

See traces with the DebugFlushCaches option from the xserver-xorg-video-intel from xorg-edgers
Comment 1 Geir Ove Myhr 2009-11-13 21:14:24 UTC
Created attachment 31193 [details]
Xorg.0.log
Comment 2 Geir Ove Myhr 2009-11-13 21:14:52 UTC
Created attachment 31194 [details]
Output of dmesg
Comment 3 nepo 2009-11-18 06:14:13 UTC
The very same happens to me: same Laptop, same graphics chip.  I currently use OpenSuse 11.2 with KDE4. Let me know, if I can help!
Best,
D.
Comment 4 Geir Ove Myhr 2009-11-20 12:38:58 UTC
Just like for bug 24789, Pierre reports that these freezes stop when the kernel parameter acpi=off is used. He also did the following tests:

-2.4 intel driver from the x-retro repository (xserver-xorg-video-intel-2.4_2.4.1-1ubuntu11~ppa1_i386.deb) => OK works, good perf
-acpi=off boot option => OK works but poors performances (i don't know why)
-nomodeset boot option => KO freezes quickly after X startup
-"options i915 modeset=0" in /etc/modprobe.d/i915-kms.conf => KO freezes quickly after X startup (normal i think it's the same conf as previous)
-option "DRI" "Off" in xorg.conf => KO freezes quickly after X startup
-Option "PM" "Off" in xorg.conf => KO freezes quickly after X startup
-Option "NoMTRR" in xorg.conf => KO freezes quickly after X startup
Comment 5 Sami Tuupanen 2009-12-26 11:30:32 UTC
Amilo M7400.. Same here.. I guess I'll run the 8.10. Installation went fine with the text mode option, but in the login only mouse is moving.
Comment 6 Chris Wilson 2010-07-17 07:35:46 UTC
Slightly circumstantial evidence for incoherency: the IPEHR doesn't match the capture batch buffer.

*** This bug has been marked as a duplicate of bug 27187 ***


bug/show.html.tmpl processed on Mar 27, 2017 at 04:44:58.
(provided by the Example extension).