Bug 25156 - Using wine on ati open source drivers causes rotated textures in Wow
Summary: Using wine on ati open source drivers causes rotated textures in Wow
Status: RESOLVED DUPLICATE of bug 23865
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2009-11-17 21:55 UTC by Jeremy Wilkins
Modified: 2009-11-18 14:26 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

3D Texture corruption (638.41 KB, image/png)
2009-11-17 21:55 UTC, Jeremy Wilkins
no flags Details
Xorg Log (202.55 KB, text/plain)
2009-11-17 21:55 UTC, Jeremy Wilkins
no flags Details

Description Jeremy Wilkins 2009-11-17 21:55:01 UTC
Created attachment 31288 [details]
3D Texture corruption

When loading World of Warcraft into a Linux computer on the AMD64 architecture using the wine binary compatibility layer the screen loads up with all textures rotated.  I am using Kubuntu Karmic kernel 2.6.31.  I tried Mesa/DRI versions from 7.4 to 7.7-devel and every kernel in between and all respond the same way.  I also tried to see if the problem persisted in i686 architecture, but it is fine in 32bit.  Using the 32bit kernel and libraries rendered everything perfectly in Kubuntu Intrepid on the 2.6.27 kernel with good acceleration.

I opened a launchpad bug prior and the url is:

I am triaging the bug here, since someone from another architecture has also reported similar issues from amd64 as well.
Comment 1 Jeremy Wilkins 2009-11-17 21:55:57 UTC
Created attachment 31289 [details]
Xorg Log
Comment 2 Maciej Cencora 2009-11-17 23:04:00 UTC
This is a known problem. Disable "Full screen glow effect" and "Depth effect" for now.
Comment 3 Jeremy Wilkins 2009-11-18 14:16:56 UTC
You are right.  Thank you for pointing this out.  I searched everywhere for this, but did not find the answer.  The problem is projectedTectures which should be disabled.  There must be a problem with its implementation in 64bit because it works in 32bit with it on.  I will post back to the launchpad item.  Is there already an open bug report here.  If so, we can mark this duplicate.
Comment 4 Maciej Cencora 2009-11-18 14:26:22 UTC

*** This bug has been marked as a duplicate of bug 23865 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.