Bug 25244 - Bad rendering of standard fonts
Summary: Bad rendering of standard fonts
Status: RESOLVED DUPLICATE of bug 5589
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-23 10:31 UTC by Dmytro Pukha
Modified: 2009-11-25 03:11 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
PDF file excerpt and results of rendering (768.37 KB, application/octet-stream)
2009-11-23 10:33 UTC, Dmytro Pukha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmytro Pukha 2009-11-23 10:31:33 UTC
Viewing a PDF file in Evince v2.28.1 (libpoppler v0.12.0) and Acrobat Reader 9.2 delivers different results in font rendering. Although the document uses only standard not-embedded fonts (Times New Roman, CourierNew and Arial), the resulting glyphs look in Evince as if they were not processed by an anti-aliasing filter whereas the same text blocks in Adobe Acrobat are much more readable (check the attached zip archive).

I'm wondering if there is an issue with non-native ttf-mscorefonts 3.0 package installed in my Ubuntu 9.10 or a poppler bug?
Comment 1 Dmytro Pukha 2009-11-23 10:33:17 UTC
Created attachment 31414 [details]
PDF file excerpt and results of rendering
Comment 2 Albert Astals Cid 2009-11-23 13:09:59 UTC
splash backend renders it much better than cairo backend, at least here
Comment 3 Dmytro Pukha 2009-11-23 13:19:54 UTC
Is there any option to choose rendering backend for poppler to be used by Evince?
Comment 4 Carlos Garcia Campos 2009-11-25 03:11:02 UTC
This is a duplicate of bug #5589, I'm working on fixing it in poppler until it's finally fixed in pixman. 

Thanks for reporting. 

*** This bug has been marked as a duplicate of bug 5589 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.