Bug 25258 - KMS and X do not use monitor's native resolution
Summary: KMS and X do not use monitor's native resolution
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: General (show other bugs)
Version: DRI git
Hardware: All Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-24 06:16 UTC by Johannes Obermayr
Modified: 2019-10-14 13:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg (59.08 KB, text/plain)
2009-11-24 06:16 UTC, Johannes Obermayr
no flags Details
Xorg.0.log (23.60 KB, text/plain)
2009-11-24 06:17 UTC, Johannes Obermayr
no flags Details
dmesg (58.58 KB, text/plain)
2009-12-03 02:26 UTC, Johannes Obermayr
no flags Details
xorg.conf (8.25 KB, text/plain)
2009-12-03 04:36 UTC, Johannes Obermayr
no flags Details
Xorg.0.log (26.48 KB, text/plain)
2009-12-03 05:08 UTC, Johannes Obermayr
no flags Details
Xorg.0.log with nv (47.41 KB, text/plain)
2010-03-06 11:29 UTC, Johannes Obermayr
no flags Details
dmesg output on ASUS E35M1-I Deluxe (85.08 KB, text/plain)
2011-05-22 09:35 UTC, Johannes Obermayr
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Obermayr 2009-11-24 06:16:03 UTC
Graphic card: Zotac IONITX (9400M)
Monitor: Hisense LCD2233EU -> HEC LCD2233EU?, native Resolution 1680x1050
Software: git20091123

KMS and X recognise my monitor with a native resolution of 1280x720. If I try setting resolution to 1680x1050 in X it switches to 1280x1024.
My monitor cannot handle a resolution of 1280x720 -> some parts are "outside" monitor's viewable area. 

Maybe https://bugs.freedesktop.org/show_bug.cgi?id=24861 is useful, too. I link provided logs here:
dmesg:      https://bugs.freedesktop.org/attachment.cgi?id=30933
Xorg.0.log: https://bugs.freedesktop.org/attachment.cgi?id=30934
xorg.conf:  https://bugs.freedesktop.org/attachment.cgi?id=30935

The problem described there with VGA->VGA connection exists with this mainboard, too.
Only HDMI->HDMI or DVI->HDMI connections work on console but with the described wrong native resolution...

Logs for DVI->HDMI connection follow...
Comment 1 Johannes Obermayr 2009-11-24 06:16:36 UTC
Created attachment 31442 [details]
dmesg
Comment 2 Johannes Obermayr 2009-11-24 06:17:16 UTC
Created attachment 31443 [details]
Xorg.0.log
Comment 3 Maarten Maathuis 2009-11-24 10:09:15 UTC
In case you didn't notice, there are bigger problems as well (the gpu lockup message in dmesg). Also the scheduling while atomic error isn't a good thing.
Comment 4 Johannes Obermayr 2009-12-03 02:26:45 UTC
Created attachment 31699 [details]
dmesg

I updated to

author    Ben Skeggs <bskeggs@redhat.com> 2009-12-03 03:53:42 (GMT)
committer Ben Skeggs <bskeggs@redhat.com> 2009-12-03 06:08:03 (GMT)
commit    6169057b2992862565c513ca432b35c4df33288a

and changed kernel flavor.

I think it looks a bit better...
Comment 5 Ben Skeggs 2009-12-03 02:46:40 UTC
Hmm, can you post your xorg.conf here too please.

The GPU hang issues are known on NVAC, I haven't been able to get my hands on one to find out what's going wrong as of yet however.
Comment 6 Johannes Obermayr 2009-12-03 04:36:10 UTC
Created attachment 31704 [details]
xorg.conf

xorg.conf which was generated by SaX2 in relation to latest dmesg.
Comment 7 Ben Skeggs 2009-12-03 04:41:10 UTC
It's likely this that's screwing things up, can you get rid of the DisplaySize, HorizSync and VertRefresh lines from the monitor section of xorg.conf and retry.
Comment 8 Johannes Obermayr 2009-12-03 05:08:17 UTC
Created attachment 31707 [details]
Xorg.0.log

(In reply to comment #7)
It does not change appearance on console/in X. Newly created Xorg.0.log after KDE's start is attached.
Comment 9 Ben Skeggs 2009-12-03 15:13:14 UTC
You still have those lines somewhere:

(II) NOUVEAU(0): Using hsync ranges from config file
(II) NOUVEAU(0): Using vrefresh ranges from config file
Comment 10 Johannes Obermayr 2009-12-03 15:46:41 UTC
There is something really wrong:

$ cat /etc/X11/xorg.conf | grep HorizSync
$ cat /etc/X11/xorg.conf | grep VertRefresh
$ cat /etc/X11/xorg.conf | grep DisplaySize

As you can see there is no output...


$ cat /var/log/Xorg.0.log | grep "config file"
Markers: (--) probed, (**) from config file, (==) default setting,
(==) Using config file: "/etc/X11/xorg.conf"
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) NOUVEAU(0): Using hsync ranges from config file
(II) NOUVEAU(0): Using vrefresh ranges from config file
(II) NOUVEAU(0): Using hsync ranges from config file
(II) NOUVEAU(0): Using vrefresh ranges from config file

And here is output...
Comment 11 Johannes Obermayr 2010-03-06 11:29:54 UTC
Created attachment 33820 [details]
Xorg.0.log with nv

ION is also working with nv driver now.

Attached is output with nv driver (for EDID) which is also 1280x720 but it fits to my monitor.

Nouveau's (invalid) EDID which "produces" output out of monitor's area:

00FFFFFFFFFFFF0020A337320100000026100103804627780A0DC9A05747982712484CBFCF0001010101010101010101010101010101011D007251D01A206E2855007E884200001A011D00BC52D01E20B8285540C48E21000018000000FC004C43443232333345550A202020000000FD0032500F440F000A202020202020015E

I hope it is useful.
Comment 12 Johannes Obermayr 2011-05-22 09:35:30 UTC
Created attachment 47007 [details]
dmesg output on ASUS E35M1-I Deluxe

Same problem on ASUS E35M1-I Deluxe (radeon).
Comment 13 Johannes Obermayr 2011-05-22 09:38:20 UTC
Assign to DRI / General since it seems to be a general problem.
Comment 14 Martin Peres 2019-10-14 13:20:04 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.