Bug 25366 - PGRAPH_ERROR with Quadro NVS 280 SD (NV17 or NV18)
Summary: PGRAPH_ERROR with Quadro NVS 280 SD (NV17 or NV18)
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: 7.5 (2009.10)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 27153 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-30 09:05 UTC by Pawel Moll
Modified: 2010-09-07 17:56 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
That's how my desktop looks like after 10-15 minutes... (548.47 KB, image/png)
2009-11-30 09:05 UTC, Pawel Moll
no flags Details
Kernel log from init to first errors... (37.65 KB, text/plain)
2009-11-30 09:06 UTC, Pawel Moll
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pawel Moll 2009-11-30 09:05:11 UTC
I've upgraded to Fedora 12 recently... As the binary drivers for my old old old card (nvidia_96xx) are not supported yet (or maybe any more ;-) I've decided to give nouveau a try.

It starts like a charm, but shortly after (a few minutes) everything goes bunkers - fonts instead of being black are light grey or pink ;-), bitmaps are corrupted. In a second I'll attach a screenshot of my screen after about 10-15 minutes.

The kernel (log to be attached as well) is screaming like this:

[drm] nouveau 0000:01:00.0: PGRAPH_ERROR - nSource: PROTECTION_ERROR, nStatus: INVALID_STATE
[drm] nouveau 0000:01:00.0: PGRAPH_ERROR - Ch 1/0 Class 0x0039 Mthd 0x0184 Data 0x000011ce:0x000011ce

My system:

$ X -version

X.Org X Server 1.7.1
Release Date: 2009-10-23
X Protocol Version 11, Revision 0
Build Operating System:  2.6.18-164.2.1.el5 
Current Operating System: Linux sedan 2.6.31.5-127.fc12.i686.PAE #1 SMP Sat Nov 7 21:25:57 EST 2009 i686
Kernel command line: ro root=LABEL=/ rhgb quiet SYSFONT=latarcyrheb-sun16 LANG=en_GB.UTF-8 KEYTABLE=pl2
Build Date: 05 November 2009  07:43:20PM
Build ID: xorg-x11-server 1.7.1-7.fc12 
Current version of pixman: 0.16.2
	Before reporting problems, check http://bodhi.fedoraproject.org/
	to make sure that you have the latest version.

The card:

01:00.0 VGA compatible controller: nVidia Corporation NV18GL [Quadro NVS 280 SD] (rev a2) (prog-if 00 [VGA controller])
	Subsystem: nVidia Corporation Device 0190
	Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin A routed to IRQ 11
	Region 0: Memory at fc000000 (32-bit, non-prefetchable) [size=16M]
	Region 1: Memory at f0000000 (32-bit, prefetchable) [size=128M]
	Expansion ROM at fd000000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel modules: nouveau, nvidiafb

As you see lspci claims it's NV18-base card, while the driver says:

[drm] nouveau 0000:01:00.0: Detected an NV17 generation card (0x018a00a3)

Any other data I can provide?
Comment 1 Pawel Moll 2009-11-30 09:05:57 UTC
Created attachment 31600 [details]
That's how my desktop looks like after 10-15 minutes...
Comment 2 Pawel Moll 2009-11-30 09:06:21 UTC
Created attachment 31601 [details]
Kernel log from init to first errors...
Comment 3 Francisco Jerez 2010-09-07 17:54:08 UTC
*** Bug 27153 has been marked as a duplicate of this bug. ***
Comment 4 Francisco Jerez 2010-09-07 17:56:26 UTC
This should be fixed with latest git, please reopen if it's not.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.