Bug 25411 - Glyph corruption after VT switch
Glyph corruption after VT switch
Status: RESOLVED DUPLICATE of bug 25406
Product: DRI
Classification: Unclassified
Component: DRM/Intel
XOrg git
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: Jesse Barnes
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-03 02:28 UTC by Dark Shadow
Modified: 2009-12-09 03:27 UTC (History)
0 users

See Also:


Attachments
Screenshot showing glyph corruption (2.32 KB, image/png)
2009-12-03 02:28 UTC, Dark Shadow
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dark Shadow 2009-12-03 02:28:46 UTC
Created attachment 31700 [details]
Screenshot showing glyph corruption

linux: 2.6.31-tuxonice
mesa: cdb6849fc1fa0c6e360c89a6388dc8bf19a746ca
mesa/drm: 57473c7f523f476ffa54c34e0c6312ffa66dcc5c
xf86-video-intel: c439207ec0cc16d7d9f523598fcdebf7cec893e2

Running compiz.

After resuming from hibernation and vt switch, glyph corruption can be seen as shown in the screenshot.

Some corruption will vanish after some time, using apps like opening new web pages in Mozilla Firefox.

This started to happen rather recently (< 1 week ago). I'll try a git bisect when I have enough time.
Comment 1 Dark Shadow 2009-12-03 04:23:40 UTC
It seems this is a bug in latest xf86-video-intel. 2.9.1 release works ok.
Comment 2 Jesse Barnes 2009-12-03 09:34:21 UTC
Can you bisect the corruption?  Chris has been making some changes in this area recently.
Comment 3 Dark Shadow 2009-12-03 09:59:18 UTC
Yes, I've already started doing this, but there is another bug caused by a later commit which makes screen and keyboard freeze after X quits. I can still ssh to the computer to issue a restart.

I will try to find the commit which causes this first and file another bug report, but as you can imagine, this makes bisecting a pain.
Comment 4 Gordon Jin 2009-12-03 17:42:10 UTC
This may be dup with bug#25409. You can firstly try reverting that commit to see if that works.
Comment 5 Chris Wilson 2009-12-09 03:27:51 UTC
I think VT switch behaves exactly like s&r in this regard and so it is likely to be using TILING_X for the glyph cache that is causing this apparent regression. The corruption does indeed seem identical and indicative of a tiling failure.

*** This bug has been marked as a duplicate of bug 25406 ***