Bug 25596 - Jaggy fonts with Cairo backend
Summary: Jaggy fonts with Cairo backend
Status: RESOLVED DUPLICATE of bug 5589
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-11 11:37 UTC by Mikhail Glushenkov
Modified: 2009-12-12 01:37 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Evince screenshot (59.83 KB, image/png)
2009-12-11 11:42 UTC, Mikhail Glushenkov
Details
Okular screenshot (342.72 KB, image/png)
2009-12-11 11:43 UTC, Mikhail Glushenkov
Details
PDF file that exhibits the bug (106.99 KB, application/pdf)
2009-12-11 11:45 UTC, Mikhail Glushenkov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Glushenkov 2009-12-11 11:37:55 UTC
Fonts in the attached file are very ugly and jaggy when the file is rendered by Poppler's Cairo backend. Note that this is not a scanned image file. 

The bug can be reproduced with current HEAD using gtk-cairo-test, and also with Evince. On the other hand, the file is rendered correctly by gtk-splash-test, Okular and xpdf. I use Ubuntu 9.10.
Comment 1 Mikhail Glushenkov 2009-12-11 11:41:35 UTC
Since the file is too large to be attached, I'm posting a link:

http://projecteuclid.org/DPubS?service=UI&version=1.0&verb=Display&handle=euclid.bams/1183555452

(You should press the "PDF File" link)
Comment 2 Mikhail Glushenkov 2009-12-11 11:42:31 UTC
Created attachment 32000 [details]
Evince screenshot
Comment 3 Mikhail Glushenkov 2009-12-11 11:43:04 UTC
Created attachment 32001 [details]
Okular screenshot
Comment 4 Mikhail Glushenkov 2009-12-11 11:45:03 UTC
Created attachment 32002 [details]
PDF file that exhibits the bug
Comment 5 Mikhail Glushenkov 2009-12-11 11:46:16 UTC
(In reply to comment #1)
> Since the file is too large to be attached, I'm posting a link:

Scratch that, found a way to post only the first page.

Comment 6 Carlos Garcia Campos 2009-12-12 01:37:00 UTC
It's a known issue, thanks for reporting. 

*** This bug has been marked as a duplicate of bug 5589 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.