Bug 25598 - [965GM] Corruption on resume from hibernation with xf86-video-intel-git
Summary: [965GM] Corruption on resume from hibernation with xf86-video-intel-git
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.5 (2009.10)
Hardware: x86 (IA32) Linux (All)
: highest critical
Assignee: Carl Worth
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-11 12:41 UTC by Anonymous Helper
Modified: 2010-01-20 09:15 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (59.33 KB, application/x-trash)
2009-12-13 22:30 UTC, Petar Velkovski
no flags Details
kern.log (571.51 KB, text/x-log)
2009-12-13 22:30 UTC, Petar Velkovski
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anonymous Helper 2009-12-11 12:41:40 UTC
Hello, 
I've been using GIT snapshots of xf86-video-intel and got some graphics corruption after resuming from hibernation today. May last update was yesterday with commit 37f631d66 (Revert "uxa-glyphs: Enable TILING_X on glyph caches) - which I suspect was made to fix these kind of things, but my display got corrupted. I am sending this report because I hope this won't happen when version 2.10 of the driver is finally released.

Some 10 minutes after resuming I noticed graphic corruption and my display hanged, it was accompanied with these messages in the kernel log: 

[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
render error detected, EIR: 0x00000000
i915: Waking up sleeping processes
[drm:i915_gem_execbuffer] *ERROR* Execbuf while wedged
[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
render error detected, EIR: 0x00000000
i915: Waking up sleeping processes
[drm:i915_wait_request] *ERROR* i915_wait_request returns -5 (awaiting 523491 at 523490)
[drm:i915_gem_execbuffer] *ERROR* Execbuf while wedged

- and so on repeating it self until I killed X -


...and these messages in the X.org log:

(WW) intel(0): i830_uxa_prepare_access: gtt bo map failed: Input/output error
(WW) intel(0): i830_uxa_pixmap_swap_bo_with_image: bo map failed
(EE) intel(0): Failed to submit batch buffer, expect rendering corruption or even a frozen display: Input/output error.
(WW) intel(0): i830_uxa_prepare_access: gtt bo map failed: Input/output error
(EE) intel(0): Failed to submit batch buffer, expect rendering corruption or even a frozen display: Input/output error.
- and so on repeating it self until I killed X -

I am using X.org 7.5 with mesa 7.6 and libdrm 2.4.16.

Let me know how I could provide more information, thank you.
Comment 1 Petar Velkovski 2009-12-13 22:20:54 UTC
What kind of corruption are you experiencing? Font corruption or something more general? Developers usually ask for a screenshot in order to see what kind of corruption occurs. The patch that you are referring to was done because of bug 25406. You can access it at http://bugs.freedesktop.org/show_bug.cgi?id=25406, If your screen corruption is related to it.
Comment 2 Petar Velkovski 2009-12-13 22:29:35 UTC
I would like to document that instead of screen corruption, I am getting screen freezes that give same messages to the Xorg.0.log and kern.log. I am on mesa 7.7 git, X.org 7.4, libdrm 2.4.16. Linux kernel 2.6.32. The graphic chip is GM945. I am also sending attachments of Xorg.0.log and kern.log.
Comment 3 Petar Velkovski 2009-12-13 22:30:17 UTC
Created attachment 32052 [details]
Xorg.0.log
Comment 4 Petar Velkovski 2009-12-13 22:30:46 UTC
Created attachment 32053 [details]
kern.log
Comment 5 Anonymous Helper 2009-12-14 10:03:07 UTC
Hello Petar, 
indeed I noticed a font corruption in Emacs which signaled something is happening, but I couldn't do anything because all windows started lagging - like moving a window was delayed by 15 seconds and then followed by a display freeze.

I suspend and hibernate my machine a lot, this did not happen on resume from suspend, not once, but I did not hibernate since then because of it.

I forgot to add to my report that last Git snapshot I used before this one was from 24.11.2009, and didn't have these problems. I also use Linux 2.6.32 and of course have KMS enabled.
Comment 6 roberth 2009-12-25 10:39:20 UTC
(In reply to comment #0)

[264301.566382] (WW) intel(0): i830_uxa_pixmap_swap_bo_with_image: bo map failed
[264301.566535] (WW) intel(0): i830_uxa_prepare_access: gtt bo map failed: Input/output error
[264301.566658] (WW) intel(0): i830_uxa_prepare_access: gtt bo map failed: Input/output error
[264301.566777] (WW) intel(0): i830_uxa_prepare_access: gtt bo map failed: Input/output error
[264301.570390] (EE) intel(0): Failed to submit batch buffer, expect rendering corruption or even a frozen display: Input/output error.

I also am getting this if I get a hang after a suspend/resume cycle. This is similar to bug 25475, only the i830_uxa_pixmap_swap_bo_with_image: bo map failed line does not appear if the execbuff while wedged crash happens prior to a suspend/resume cycle. When this hang happens, I can't switch to a VT unlike the hangs in bug 25475. It is hard to reproduce this one to submit a dump because I am not usually in a situation where I can ssh in from another machine to do when it happens coupled with VT's not working.
Comment 7 roberth 2009-12-25 11:04:15 UTC
(In reply to comment #6)

I forgot to mention, but reverting libdrm to a 2.4.15 checkout from 11-25 up to commit 6f66de982ad6ee6967ec61a7399e600bdd9e5887 also fixes this problem for me as it does the bug 25475 problem, but that is not a good solution because 2.4.16 is needed to build intel now and 2.4.16 release from 12-03 also exibits this problem.
Comment 8 Anonymous Helper 2010-01-03 12:24:47 UTC
It has been (almost)a month since my initial report. I am now running the following: 

xf86-video-intel 2.9.99.902
intel-dri / mesa 7.7
libdrm 2.4.17
linux 2.6.32.2

I have not seen this bug in two weeks, I suspend daily and hibernate ocasionally.

The reports linked by other people suggest there are some problems with the driver, maybe even more than one, but at the moment I am unable to reproduce any of it on my machine. Being that there are multiple reports on the same issue, and I can't reporoduce the problem I have no objections to closing this bug report.
Comment 9 Eric Anholt 2010-01-20 09:15:02 UTC
Reporter says it's fixed.  If you're not the reporter and you're having an issue like this, please open your own bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.