Bug 25619 - nouveau fails to detect connected monitor on nforce1 (nv1a)
Summary: nouveau fails to detect connected monitor on nforce1 (nv1a)
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 25786 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-13 05:47 UTC by Bruno
Modified: 2010-02-11 11:40 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Kernel log (42.01 KB, text/plain)
2009-12-13 05:47 UTC, Bruno
no flags Details
VBIOS extracted with dd if=/dev/mem of=vbios.rom bs=1k skip=768 count=64 (64.00 KB, application/octet-stream)
2009-12-13 05:57 UTC, Bruno
no flags Details
additional kernel log with drm.debug=4 (set via sysfs) and modprobing nouveau (33.73 KB, text/plain)
2009-12-13 06:55 UTC, Bruno
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno 2009-12-13 05:47:45 UTC
Created attachment 32037 [details]
Kernel log

System is MSI K7N420 Pro, using the onboard nforce graphics.

lspci:
00:00.0 Host bridge [0600]: nVidia Corporation nForce CPU bridge [10de:01a4] (rev b2)
00:00.1 RAM memory [0500]: nVidia Corporation nForce 220/420 Memory Controller [10de:01ac] (rev b2)
00:00.2 RAM memory [0500]: nVidia Corporation nForce 220/420 Memory Controller [10de:01ad] (rev b2)
00:00.3 RAM memory [0500]: nVidia Corporation nForce 420 Memory Controller (DDR) [10de:01ab] (rev b2)
00:01.0 ISA bridge [0601]: nVidia Corporation nForce ISA Bridge [10de:01b2] (rev c3)
00:01.1 SMBus [0c05]: nVidia Corporation nForce PCI System Management [10de:01b4] (rev c1)
00:02.0 USB Controller [0c03]: nVidia Corporation nForce USB Controller [10de:01c2] (rev c3)
00:03.0 USB Controller [0c03]: nVidia Corporation nForce USB Controller [10de:01c2] (rev c3)
00:04.0 Ethernet controller [0200]: nVidia Corporation nForce Ethernet Controller [10de:01c3] (rev c2)
00:05.0 Multimedia audio controller [0401]: nVidia Corporation nForce Audio Processing Unit [10de:01b0] (rev c2)
00:06.0 Multimedia audio controller [0401]: nVidia Corporation nForce AC'97 Audio Controller [10de:01b1] (rev c2)
00:08.0 PCI bridge [0604]: nVidia Corporation nForce PCI-to-PCI bridge [10de:01b8] (rev c2)
00:09.0 IDE interface [0101]: nVidia Corporation nForce IDE [10de:01bc] (rev c3)
00:1e.0 PCI bridge [0604]: nVidia Corporation nForce AGP to PCI Bridge [10de:01b7] (rev b2)
01:00.0 USB Controller [0c03]: NEC Corporation USB [1033:0035] (rev 41)
01:00.1 USB Controller [0c03]: NEC Corporation USB [1033:0035] (rev 41)
01:00.2 USB Controller [0c03]: NEC Corporation USB 2.0 [1033:00e0] (rev 02)
01:02.0 VGA compatible controller [0300]: Cirrus Logic GD 5446 [1013:00b8]
02:00.0 VGA compatible controller [0300]: nVidia Corporation NVCrush11 [GeForce2 MX Integrated Graphics] [10de:01a0] (rev b1)

When loading nouveau, display goes into standby mode (no signal).
Unloading an loading nouveau again does not change anything.

nvidiafb is able to get the display running.
Comment 1 Bruno 2009-12-13 05:57:58 UTC
Created attachment 32038 [details]
VBIOS extracted with dd if=/dev/mem of=vbios.rom bs=1k skip=768 count=64
Comment 2 Bruno 2009-12-13 06:55:22 UTC
Created attachment 32040 [details]
additional kernel log with drm.debug=4 (set via sysfs) and modprobing nouveau
Comment 3 Rajeev V. Pillai 2009-12-23 23:26:24 UTC
*** Bug 25786 has been marked as a duplicate of this bug. ***
Comment 4 Rajeev V. Pillai 2010-02-10 16:06:50 UTC
Commit id=d5f669822059651c4db1be94cbab605e1ba5a389 fixes the bug for me. The nouveau kernel module now says: "Load detected on head A".

Thanks.
Comment 5 Francisco Jerez 2010-02-11 03:41:19 UTC
(In reply to comment #4)
> Commit id=d5f669822059651c4db1be94cbab605e1ba5a389 fixes the bug for me. The
> nouveau kernel module now says: "Load detected on head A".
> 
Okay, thanks, I'm marking this as fixed.

> Thanks.
> 
Comment 6 Bruno 2010-02-11 11:40:25 UTC
(In reply to comment #4)
> Commit id=d5f669822059651c4db1be94cbab605e1ba5a389 fixes the bug for me. The
> nouveau kernel module now says: "Load detected on head A".

Fixes it for me too (but no EDID, though this is a new issue)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.