Bug 25760 - NEW Mali Keyboard Layout
NEW Mali Keyboard Layout
Status: RESOLVED FIXED
Product: xkeyboard-config
Classification: Unclassified
Component: General
unspecified
All All
: medium normal
Assigned To: xkb
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-22 08:37 UTC by reg
Modified: 2013-04-01 23:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Mali Layout (3.25 KB, text/plain)
2009-12-22 08:37 UTC, reg
Details
Fixed Mali Layout (4.24 KB, text/plain)
2009-12-22 09:05 UTC, reg
Details
Mali Layout - Fixed Group Names (3.29 KB, text/plain)
2009-12-31 02:13 UTC, reg
Details
base.xml.in Mali Layout (688 bytes, application/octet-stream)
2009-12-31 02:14 UTC, reg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description reg 2009-12-22 08:37:23 UTC
Created attachment 32247 [details]
Mali Layout

There is no keyboard layout to type Mali languages characters easily.

Attached is the Mali layout including a couple variants.

Please note that while I've set name to 'mali', it should be 'ml' but there seem to be a bug somewhere (either freedesktop or gnome keyboard properties) which makes it conflicts with the Malayalam layout: ML is Mali ISO 3166-1 country code and ML is also Malayalam ISO 639-1 language code.

-- bellow is the base layout extract --
    <layout>
      <configItem>
        <name>mali</name>
        <shortDescription>Mali</shortDescription>
        <description>Mali</description>
        <languageList><iso639Id>bam</iso639Id></languageList>
      </configItem>
      <variantList>
        <variant>
          <configItem>
            <name>fr</name>
            <description>Français (France)</description>
          </configItem>
        </variant>
        <variant>
          <configItem>
            <name>fross</name>
            <description>Français (France - Alternative)</description>
          </configItem>
        </variant>
        <variant>
          <configItem>
            <name>usmac</name>
            <description>English (USA - Macintosh)</description>
          </configItem>
        </variant>
        <variant>
          <configItem>
            <name>usintl</name>
            <description>English (USA - International)</description>
          </configItem>
        </variant>
      </variantList>
    </layout>
--
Comment 1 reg 2009-12-22 08:43:24 UTC
(In reply to comment #0)
> Please note that while I've set name to 'mali', it should be 'ml' but there
> seem to be a bug somewhere (either freedesktop or gnome keyboard properties)
> which makes it conflicts with the Malayalam layout: ML is Mali ISO 3166-1
> country code and ML is also Malayalam ISO 639-1 language code.

My bad, I just realize I missed the <countryList><iso3166Id> tags.
Will update the report in a bit.
Comment 2 reg 2009-12-22 09:05:34 UTC
Created attachment 32248 [details]
Fixed Mali Layout
Comment 3 reg 2009-12-22 09:06:59 UTC
Well,

All my apologies for talking about a bug which doesn't exist ; I should have
read the DTD more carefully.

Attached is the fixed layout and bellow the fixed base extract

--
    <layout>
      <configItem>
        <name>mali</name>
        <shortDescription>Mali</shortDescription>
        <description>Mali</description>
        <countryList><iso3166Id>ML</iso3166Id></countryList>
        <languageList><iso639Id>BAM</iso639Id></languageList>
      </configItem>
      <variantList>
        <variant>
          <configItem>
            <name>fr</name>
            <description>Français (France)</description>
          </configItem>
        </variant>
        <variant>
          <configItem>
            <name>fross</name>
            <description>Français (France - Alternative)</description>
          </configItem>
        </variant>
        <variant>
          <configItem>
            <name>usmac</name>
            <description>English (USA - Macintosh)</description>
          </configItem>
        </variant>
        <variant>
          <configItem>
            <name>usintl</name>
            <description>English (USA - International)</description>
          </configItem>
        </variant>
      </variantList>
    </layout>
-- 
Comment 4 Sergey V. Udaltsov 2009-12-30 08:41:22 UTC
Are you sure the group names are correct???

Also, about base.xml.in - the default layout should not be listed among variants.

Please have a look at http://www.freedesktop.org/wiki/Software/XKeyboardConfig/Rules
Comment 5 reg 2009-12-31 02:13:37 UTC
Created attachment 32381 [details]
Mali Layout - Fixed Group Names
Comment 6 reg 2009-12-31 02:14:18 UTC
Created attachment 32382 [details]
base.xml.in Mali Layout
Comment 7 reg 2009-12-31 02:20:01 UTC
Thanks Sergey for the Rules URI. I haven't found those.

> Are you sure the group names are correct???

There were wrong according to the rules. Now fixed.

> Also, about base.xml.in - the default layout should not be listed among
variants.

Right, also fixed.

I also fixed some cosmetics in the layout file according to the rules.

Thank you for your comments,

-- 

Please note that the name of the layout (and thus <name> value in base.xml.in) should be "ml" because that's the iso3166 code of Mali. I decided not to follow the rules because if I do then gnome-keyboard-properties (haven't tested lower levels) confuses the layout with Malayalam language.
Comment 8 Sergey V. Udaltsov 2010-01-28 15:52:52 UTC
I committed your code. But the filename would be still ml, because that's what ISO tells us. I checked with my version of gnome - it recognizes Mali properly.

Thanks for your code!
Comment 9 Simos Xenitellis 2010-07-01 14:11:07 UTC
A user reported that if you select Mali and any of the variants, you actually get Malayalam,
https://bugs.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/575660

I tried and I can replicate that instead of Mali, you get Malayalam.

gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
says
 layouts = [us,ml]
 options = [Compose key	compose:menu,grp	grp:shifts_toggle]
 model = 

The keyboard display in GNOME shows the Mali variants but the keyboard itself shows Malayalam characters.

(btw, all this xkc traffic is due to https://wiki.ubuntu.com/UbuntuBugDay/20100701 ;-)
Comment 10 Sergey V. Udaltsov 2010-07-01 14:22:58 UTC
I managed to reproduce, but that issue was caused by the bug in the Indian layout. Please try from git
Comment 11 Simos Xenitellis 2010-07-01 16:38:29 UTC
(In reply to comment #10)
> I managed to reproduce, but that issue was caused by the bug in the Indian
> layout. Please try from git

Which bug from the Indian layout are you referring to? Is it a known bug?
Comment 12 Sergey V. Udaltsov 2010-07-01 16:39:52 UTC
No, I just found it today trying to configure ml layout.

http://cgit.freedesktop.org/xkeyboard-config/commit/?id=393204e792de332457b1175b3831170d6970a98f