Bug 25897 - xorg-server 1.7 causes drivers to compute incorrect DPI
Summary: xorg-server 1.7 causes drivers to compute incorrect DPI
Status: RESOLVED DUPLICATE of bug 23705
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: 7.5 (2009.10)
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-04 19:36 UTC by Nick Bowler
Modified: 2010-01-05 02:10 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg log (13.27 KB, text/plain)
2010-01-04 19:36 UTC, Nick Bowler
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Bowler 2010-01-04 19:36:47 UTC
Created attachment 32451 [details]
Xorg log

Upgrading to xorg-server 1.7 caused my intel driver to report the incorrect
screen size of 444 x 277 millimetres (96 x 96 DPI), as shown from the log
excerpt:

(II) intel(0): Using exact sizes for initial modes
(II) intel(0): Output LVDS1 using initial mode 1680x1050
(II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
(==) intel(0): DPI set to (96, 96)
...
(II) intel(0): Setting screen physical size to 444 x 277

However, xrandr reports the correct screen size of 331mm x 207mm, and running
xrandr --fbmm 331x207 results in the corect DPI (129x129) being configured.

The problem is reproducible on all my machines, two with intel and one with radeon -- they all get set to the incorrect DPI of 96x96.  xorg-server 1.6 does not exhibit the issue.
Comment 1 Julien Cristau 2010-01-05 02:10:03 UTC

*** This bug has been marked as a duplicate of bug 23705 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.