Bug 26026 - Incorrect rendering (missing grayscale)
Summary: Incorrect rendering (missing grayscale)
Status: RESOLVED DUPLICATE of bug 5589
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-13 07:02 UTC by Frederic Crozat
Modified: 2010-01-15 06:32 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
PDF where grayscales are not rendered (compressed) (978.86 KB, application/x-bzip)
2010-01-13 07:04 UTC, Frederic Crozat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Crozat 2010-01-13 07:02:23 UTC
Attached PDF is correctly rendered by splash backend (or okular or even xpdf) but not by cairo backend.

It seems grayscales are not rendered at all.

This is with poppler 0.12.1 or even fresh git checkout.
Comment 1 Frederic Crozat 2010-01-13 07:04:56 UTC
Created attachment 32614 [details]
PDF where grayscales are not rendered (compressed)
Comment 2 Carlos Garcia Campos 2010-01-13 07:21:25 UTC
hmm, I'm not sure, but I'd say this is because of  cairo poor quiality downscaling. See bug 5589
Comment 3 Frederic Crozat 2010-01-15 06:32:34 UTC
It is indeed a dup from bug 5589, it is fixed when I used workaround patch in this bug.

*** This bug has been marked as a duplicate of bug 5589 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.