Bug 26194 - nouveau reports DPI correctly in Xorg.0.log, but value reported by X incorrect
Summary: nouveau reports DPI correctly in Xorg.0.log, but value reported by X incorrect
Status: RESOLVED DUPLICATE of bug 23705
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-24 06:22 UTC by Brian Tarricone
Modified: 2010-01-24 14:56 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Tarricone 2010-01-24 06:22:44 UTC
A bit odd:

$ grep -E 'DPI|dimensions' /var/log/Xorg.0.log
(**) NOUVEAU(0): Display dimensions: (290, 180) mm
(**) NOUVEAU(0): DPI set to (112, 112)

290mm x 180mm and 112x112 DPI are indeed correct (1280x800, 13.3" widescreen), however:

$ xdpyinfo | grep -E 'dimensions|resolution'
  dimensions:    1280x800 pixels (338x211 millimeters)
  resolution:    96x96 dots per inch

X appears to be getting bogus data, which screws up font sizing.

I'm on a MacBook Pro 13" with GeForce 9400M (NVac).  Using nouveau-drm from the
kernel tree with git rev eeec3a1ecd703d3a32fe223274d2a77686030d78 (built out of
tree for kernel 2.6.32-gentoo-r2), and xf86-video-nouveau git rev
2630a1553d560ce2c7391bc103d4a543f7d3d0da.

If there's any more data or info I can provide, please let me know.
Comment 1 Julien Cristau 2010-01-24 06:37:29 UTC

*** This bug has been marked as a duplicate of bug 23705 ***
Comment 2 Brian Tarricone 2010-01-24 14:56:51 UTC
(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of bug 23705 ***

Are you sure this is a dupe?  That bug seems to refer to a general problem with xorg-server 1.7.  When I use 'nvidia' instead of 'nouveau', my DPI is reported correctly.  So it sounds like this is something that the video driver does indeed have control over.

(If it's not *appropriate* for the video driver to 'unbreak' this, then of course I understand.)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.