Bug 26196 - No mouse input in doom3 or ut2004 with KMS enabled
Summary: No mouse input in doom3 or ut2004 with KMS enabled
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2010-01-24 07:40 UTC by Adam K Kirchhoff
Modified: 2010-01-24 09:37 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Adam K Kirchhoff 2010-01-24 07:40:57 UTC
I'm using 2.6.33-rc5 and xf86-video-ati and Mesa from git as of 12/24/2010.  If I start either doom3 or ut2004, I get no mouse input.  doom3 throws errors related to XF86DGANoDirectVideoMode.    While I know that DGA is deprecated, and KMS has issues DGA, ut2004, at least, previously worked fine with KMS disabled (and I'm fairly certain I tested doom3 previously as well, and that the mouse worked fine).  MAD's commented on #radeon that it should work.

Unfortunately, the only way to get acceptable performance in doom3 with the arb2 render path is with accelerated blit, which requires KMS.
Comment 1 Adam K Kirchhoff 2010-01-24 07:41:33 UTC
Sorry, mesa and xf86-video-ati are up-to-date from git as of 01/24/2010, not 12/24/2010 :-)
Comment 2 Adam K Kirchhoff 2010-01-24 08:56:40 UTC
And I probably should have mentioned that this is on two separate machines, one with an HD4350 and one with an HD4850.
Comment 3 hadack 2010-01-24 09:24:10 UTC
You can work around this problem by setting this env varbiable: SDL_VIDEO_X11_DGAMOUSE=0, and i think doom3 has an option for that in its .cfg file
Comment 4 Adam K Kirchhoff 2010-01-24 09:37:37 UTC
Sorry for the noise.  That seems to be the answer.  Thanks :-)

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.