Bug 2624 - Intel 915 (82915G) wide-screen resolutions do not work
Summary: Intel 915 (82915G) wide-screen resolutions do not work
Status: RESOLVED DUPLICATE of bug 643
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 6.8.1
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Alan Hourihane
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-27 10:58 UTC by Joe Cooper
Modified: 2007-05-03 03:06 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log for Intel 915 (98.46 KB, text/plain)
2005-02-27 13:47 UTC, Joe Cooper
no flags Details
xorg.conf for Intel 915 (2.87 KB, text/plain)
2005-02-27 13:54 UTC, Joe Cooper
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Cooper 2005-02-27 10:58:11 UTC
This chipset exhibits the same problem described in bug 2417 for the Intel 855.
 Wide screen resolutions are not available to X.org (while they are under
Windows).  The fix for 855 (Alain Poirier's 855resolution) does not work for the
915, but it is probably not too far off.

Here's the lspci -v for the video controller:

00:02.0 VGA compatible controller: Intel Corp. 82915G Express Chipset Family
Graphics Controller (rev 04) (prog-if 00 [VGA])
        Subsystem: Holco Enterprise Co, Ltd/Shuttle Computer: Unknown device fb81
        Flags: bus master, fast devsel, latency 0, IRQ 185
        Memory at d0200000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at e400 [size=8]
        Memory at c0000000 (32-bit, prefetchable) [size=256M]
        Memory at d0280000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: [d0] Power Management version 2


I can provide Xorg.log or any further information needed.
Comment 1 Alan Hourihane 2005-02-27 11:31:04 UTC
Can you post your X log ?
Comment 2 Joe Cooper 2005-02-27 13:47:49 UTC
Created attachment 1984 [details]
Xorg.0.log for Intel 915

Here's my most recent run of X.
Comment 3 Joe Cooper 2005-02-27 13:54:50 UTC
Created attachment 1985 [details]
xorg.conf for Intel 915

I've got an additional modeline defined for a Dell FP 2005 monitor (max
resolution 1680x1050), which I've confirmed works with an nVidia 6600 video
card that I installed temporarily in the machine to be sure I had the
configuration correct.	I've got a Dell 700m laptop with a widescreen display
and the 855 chipset, which I've configured similarly that works once
855resolution has been used to reset the video BIOS modes.
Comment 4 Alan Hourihane 2005-03-29 03:45:20 UTC

*** This bug has been marked as a duplicate of 643 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.