Bug 2637 - Fatal server error forces system shutdown
Summary: Fatal server error forces system shutdown
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: 6.7.0
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords: want-backtrace
Depends on:
Blocks:
 
Reported: 2005-03-02 02:16 UTC by Roberto De Renzi
Modified: 2007-02-22 14:26 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roberto De Renzi 2005-03-02 02:16:35 UTC
I think this might be related to other instances of server crash like 
659 1390 2496.
Symptoms: X freezes and the system shuts down. The console is not responding. It
is not possible to abort X with CtrlAltBackspace as it usually is.
I cannot log into my machine even with ssh from another machine. Hence I have to
force a restart by hardware reset.

 This happens to me reproducibly when trying to look at specific e-mails with
Mozilla, but also, not as reproducibly, when moving the Mozilla window.

Xorg.0.log ends on 
Fatal server error:
Caught signal 11.  Server aborting

The corresponding lines in messages, starting from last regular operation to
restart, are

Mar  1 16:33:54 pc34 kernel: input: USB HID v1.00 Mouse [413c:3010] on
usb-0000:00:1d.1-1
Mar  2 10:02:18 pc34 gconfd (derenzi-4126): Received signal 1, shutting down cleanly
Mar  2 10:02:18 pc34 gconfd (derenzi-4126): Exiting
Mar  2 10:02:18 pc34 gdm[3665]: gdm_slave_xioerror_handler: Fatal X error -
Restarting :0
Mar  2 10:02:18 pc34 gdm(pam_unix)[3665]: session closed for user derenzi
Mar  2 10:02:19 pc34 su(pam_unix)[4272]: session closed for user root
Mar  2 10:03:53 pc34 syslogd 1.4.1: restart.


A couple of times I got a warning at startup saying that the CPU shut down
because it was too hot (however the air from the fan was cool and during the
subsequent startup - a couple of seconds later - dmesg  reported 51 C)


System: Dell Inspiron 8600 with ATI Mobility Radeon 9600 M10
Fedora Core 2 
kernel 2.6.10-1.12_FC2
xorg-x11 6.7.0-11
Comment 1 Adam Jackson 2005-07-03 14:49:43 UTC
starting with the 6.8.99.14 snapshot, on linux systems, the X server can print
its own backtrace when it crashes.  please confirm that these bugs are still
valid with 6.8.99.14 or later, and if they are please attach a the server log
from the crash.
Comment 2 Adam Jackson 2006-04-15 05:38:22 UTC
reporter, please verify that this is still an issue for you with a reasonably
current X, and if so please attach the X log from the crash.
Comment 3 Timo Jyrinki 2007-02-22 14:26:33 UTC
Marking broken (status null/blank) bugs in xorg with no activity in a long time as fixed. Please reopen if you think it's necessary, but first do a search if a similar bug report is already filed and in a NEW/ASSIGNED state. These bugs do not currently show in most search results as they do not have any status.

Sorry for this janitorial spam, you know where to send hate mails to when your inbox gets full of bugs you're subscribed to.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.