Bug 26450 - crash in plymouth with radeon.dynpm=1
Summary: crash in plymouth with radeon.dynpm=1
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2010-02-05 11:21 UTC by Kevin DeKorte
Modified: 2010-12-21 10:06 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Kevin DeKorte 2010-02-05 11:21:48 UTC
Using git a87a52ebe2b68cd1fad1b25141a73eca3aadf158 in drm-radeon-testing

If I boot without radeon.dynpm=1, the machine boots to gdm just fine.

If I boot with radeon.dynpm=1, plymouth starts, but hangs when it is ready to transition to gdm. At this point you can still ssh to the box. And doing dmesg I get the below kernel fault.

I believe it is caused by 898e61d5a3c977de119a3b5f60bfcb6c496b7382

plymouth is plymouth-0.8.0-0.2009.

video card is rv635 

01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3600 Series (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device 01da
	Flags: bus master, fast devsel, latency 0, IRQ 29
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Memory at fe9e0000 (64-bit, non-prefetchable) [size=64K]
	I/O ports at d000 [size=256]
	[virtual] Expansion ROM at fe900000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: radeon
	Kernel modules: radeon

machine is dual head

dmesg | grep drm
[drm] Initialized drm 1.1.0 20060810
[drm] radeon defaulting to kernel modesetting.
[drm] radeon kernel modesetting enabled.
[drm] radeon: Initializing kernel modesetting.
[drm] register mmio base: 0xFE9E0000
[drm] register mmio size: 65536
[drm] Clocks initialized !
[drm] 4 Power State(s)
[drm] State 0 Default (default)
[drm] 	16 PCIE Lanes
[drm] 	3 Clock Mode(s)
[drm] 		0 engine/memory: 725000/500000
[drm] 		1 engine/memory: 725000/500000
[drm] 		2 engine/memory: 725000/500000
[drm] State 1 Performance 
[drm] 	16 PCIE Lanes
[drm] 	3 Clock Mode(s)
[drm] 		0 engine/memory: 110000/500000
[drm] 		1 engine/memory: 300000/500000
[drm] 		2 engine/memory: 725000/500000
[drm] State 2 Default 
[drm] 	16 PCIE Lanes
[drm] 	3 Clock Mode(s)
[drm] 		0 engine/memory: 600000/500000
[drm] 		1 engine/memory: 600000/500000
[drm] 		2 engine/memory: 600000/500000
[drm] State 3 Performance 
[drm] 	16 PCIE Lanes
[drm] 	3 Clock Mode(s)
[drm] 		0 engine/memory: 300000/500000
[drm] 		1 engine/memory: 300000/500000
[drm] 		2 engine/memory: 725000/500000
[drm] radeon: power management initialized
[drm] Detected VRAM RAM=256M, BAR=256M
[drm] RAM width 128bits DDR
[drm] radeon: 256M of VRAM memory ready
[drm] radeon: 512M of GTT memory ready.
[drm] radeon: using MSI.
[drm] radeon: irq initialized.
[drm] GART: num cpu pages 131072, num gpu pages 131072
[drm] Loading RV635 Microcode
[drm] ring test succeeded in 1 usecs
[drm] radeon: ib pool ready.
[drm] ib test succeeded in 0 usecs
[drm] Enabling audio support
[drm] Default TV standard: NTSC
[drm] Radeon Display Connectors
[drm] Connector 0:
[drm]   DVI-I
[drm]   HPD1
[drm]   DDC: 0x7e50 0x7e50 0x7e54 0x7e54 0x7e58 0x7e58 0x7e5c 0x7e5c
[drm]   Encoders:
[drm] Connector 1:
[drm]   DIN
[drm]   Encoders:
[drm] Connector 2:
[drm]   DVI-I
[drm]   HPD2
[drm]   DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c
[drm]   Encoders:
[drm] fb mappable at 0xD0141000
[drm] vram apper at 0xD0000000
[drm] size 7257600
[drm] fb depth is 24
[drm]    pitch is 6912
fb0: radeondrmfb frame buffer device
[drm] Initialized radeon 2.0.0 20080528 for 0000:01:00.0 on minor 0
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id


[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
BUG: unable to handle kernel NULL pointer dereference at 0000000000000148
IP: [<ffffffffa00d073b>] radeon_pm_compute_clocks+0x7b/0x21e [radeon]
PGD 2132b6067 PUD 21329c067 PMD 0 
Oops: 0000 [#1] SMP 
last sysfs file: /sys/devices/virtual/net/lo/type
CPU 1 
Modules linked in: stp llc tun hwmon_vid coretemp sunrpc cpufreq_ondemand acpi_cpufreq freq_table ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 kvm_intel kvm uinput snd_hda_codec_atihdmi snd_hda_codec_intelhdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_seq snd_usb_audio snd_usb_lib snd_rawmidi snd_seq_device snd_pcm snd_hwdep snd_timer pwc snd videodev v4l1_compat iTCO_wdt atl1 iTCO_vendor_support v4l2_compat_ioctl32 soundcore mii serio_raw asus_atk0110 pcspkr i2c_i801 snd_page_alloc joydev dm_multipath firewire_ohci firewire_core crc_itu_t usb_storage radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: microcode]
Pid: 167, comm: plymouthd Not tainted 2.6.32 #17 P5E-VM HDMI
RIP: 0010:[<ffffffffa00d073b>]  [<ffffffffa00d073b>] radeon_pm_compute_clocks+0x7b/0x21e [radeon]
RSP: 0018:ffff880213237b18  EFLAGS: 00010203
RAX: ffff88021314a400 RBX: ffff880210068e58 RCX: 0000000000000000
RDX: 0000000000000001 RSI: 0000000000000001 RDI: 0000000000000001
RBP: ffff880213237b38 R08: 0000000000000000 R09: ffff880213237a68
R10: 000000000000ea06 R11: ffff880213237b58 R12: ffff880210068000
R13: ffff880212864488 R14: 0000000000000001 R15: ffff8802106e1a00
FS:  00007ffe70cf1700(0000) GS:ffff880028280000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 0000000000000148 CR3: 0000000213089000 CR4: 00000000000026e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process plymouthd (pid: 167, threadinfo ffff880213236000, task ffff8802100f1750)
 ffff880213237b58 ffff8802106e1600 0000000000000003 ffff880210068000
<0> ffff880213237b88 ffffffffa009e82a ffff880200000014 ffffffff00000000
<0> ffff880200000000 ffffffffa005284a 0000100000000004 ffff8802106e1600
Call Trace:
 [<ffffffffa009e82a>] radeon_atom_encoder_dpms+0x17d/0x19c [radeon]
 [<ffffffffa005284a>] ? kzalloc.clone.0+0x13/0x15 [drm_kms_helper]
 [<ffffffffa0051c2f>] drm_helper_disable_unused_functions+0xdc/0x16f [drm_kms_helper]
 [<ffffffffa0052e34>] drm_crtc_helper_set_config+0x5e8/0x778 [drm_kms_helper]
 [<ffffffffa0022a31>] drm_framebuffer_cleanup+0x59/0xb9 [drm]
 [<ffffffffa009f692>] radeon_user_framebuffer_destroy+0x62/0x6f [radeon]
 [<ffffffffa0023385>] drm_mode_rmfb+0xc6/0xda [drm]
 [<ffffffffa0019218>] drm_ioctl+0x26d/0x335 [drm]
 [<ffffffffa00232bf>] ? drm_mode_rmfb+0x0/0xda [drm]
 [<ffffffff811e782b>] ? inode_has_perm+0x7a/0x90
 [<ffffffff81106993>] ? virt_to_head_page+0xe/0x2f
 [<ffffffff810f1dfd>] ? mmap_region+0x442/0x498
 [<ffffffff81123bf8>] vfs_ioctl+0x22/0x87
 [<ffffffff81124154>] do_vfs_ioctl+0x47b/0x4c1
 [<ffffffff811241f0>] sys_ioctl+0x56/0x79
 [<ffffffff81011cb2>] system_call_fastpath+0x16/0x1b
Code: 00 be 01 00 00 00 48 2d 60 01 00 00 eb 3a 48 8b 88 40 03 00 00 48 85 c9 74 21 83 b8 20 03 00 00 03 74 18 48 8b 49 30 89 f7 ff c2 <8b> 89 48 01 00 00 d3 e7 41 09 bc 24 fc 0e 00 00 48 8b 80 60 01 
RIP  [<ffffffffa00d073b>] radeon_pm_compute_clocks+0x7b/0x21e [radeon]
 RSP <ffff880213237b18>
CR2: 0000000000000148
---[ end trace 42cd5aaea4438ddc ]---
Comment 1 Kevin DeKorte 2010-02-23 09:38:41 UTC
Tried with git aa5120d2ef228042416d3023fb7eda9ee487dcf9 in drm-radeon-testing and the crash still occurs when dynpm=1
Comment 2 Kevin DeKorte 2010-12-21 10:06:22 UTC
Appears to be fixed.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.