Bug 26546 - linux 2.6.33-rc7+git hangs on booting MacBookPro5,3 ...
Summary: linux 2.6.33-rc7+git hangs on booting MacBookPro5,3 ...
Status: RESOLVED DUPLICATE of bug 27501
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-12 08:55 UTC by Soeren Sonnenburg
Modified: 2014-09-16 11:10 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Soeren Sonnenburg 2010-02-12 08:55:01 UTC
when doing efi based boots (via elilo) after loading firmware and initialising fifo 1...

lspci:

02:00.0 VGA compatible controller: nVidia Corporation G96 [GeForce 9600M GT] (rev a1)
03:00.0 VGA compatible controller: nVidia Corporation C79 [GeForce 9400M] (rev b1)

The kernel is most recent git...


Please reassign if I screwed up the bug assignment to xorg...
Comment 1 Christopher James Halse Rogers 2010-04-06 17:30:26 UTC
There's not a lot of detail here.  Could you check out https://bugs.freedesktop.org/show_bug.cgi?id=27501 - I'm pretty sure that will be your bug, and it's got a work-around.
Comment 2 Ilia Mirkin 2013-08-18 18:09:22 UTC
It appears that this bug report has laid dormant for quite a while. Sorry we haven't gotten to it. Since we fix bugs all the time, chances are pretty good that your issue has been fixed with the latest software. Please give it a shot. (Linux kernel 3.10.7, xf86-video-nouveau 1.0.9, mesa 9.1.6, or their git versions.) If upgrading to the latest isn't an option for you, your distro's bugzilla is probably the right destination for your bug report.

In an effort to clean up our bug list, we're pre-emptively closing all bugs that haven't seen updates since 2011. If the original issue remains, please make sure to provide fresh info, see http://nouveau.freedesktop.org/wiki/Bugs/ for what we need to see, and re-open this one.

Thanks,

The Nouveau Team
Comment 3 Pierre Moreau 2014-09-16 11:10:20 UTC
As suggested by Christopher, you should check out bug 27501: I published a patch to get the 9400M  acceleration to work, but it will disable the 9600M GT as there are still some problems with having both cards enabled.

*** This bug has been marked as a duplicate of bug 27501 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.