Bug 26568 - Xv Corruption and X Lockup w/ Nouveau on C51 (Geforce 6150 Go)
Summary: Xv Corruption and X Lockup w/ Nouveau on C51 (Geforce 6150 Go)
Status: RESOLVED INVALID
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: 7.5 (2009.10)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-14 15:57 UTC by Jeremy Uchitel
Modified: 2013-08-18 18:09 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
/var/log/messages (90.15 KB, text/plain)
2010-02-14 16:00 UTC, Jeremy Uchitel
no flags Details
Xorg.0.log (20.30 KB, text/plain)
2010-02-14 16:02 UTC, Jeremy Uchitel
no flags Details
Image of flickering stripes when playing video with xv. (242.28 KB, image/png)
2010-05-15 06:30 UTC, Jeremy Uchitel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Uchitel 2010-02-14 15:57:48 UTC
I've spent some quality time with my HP tx2000 laptop this weekend because many
of the bugs I've previously reported here were still present in the mid-January
kernel/drm/ddx software that I had been using.  But they do not always appear and performance is definitely better than the stock F12 packages (or any 
available updates) So, before coming back to you with an new bug entry, I 
updated everything to the latest versions I could get to verify that the bugs are present in the most recent work:

So, on my HP tx2000 running the C51 chipset I am running Fedora 12 updated as
follows:

kernel-2.6.32.8-48.rc2.fc12 from koji
nouveau master snapshot on 12-Feb-2010
libdrm pulled from git on 13-Feb-2010
nouveau xorg ddx pulled from git on 13-Feb-2010
firmware from 29-Dec-2009
x server xorg-x11-server-1.7.4-3.fc12

Everything is compiled and installed (with a properly updated initramfs).

Here's the main problem I'm seeing: xv does not always work.  I'm using xine
(or the xine backend for kde players).  I have a number of mpeg2 vids captured
with mythtv or home movies I am putting on DVD.  I can play any video with xshm
with no problem.  With xv, 480i and 720p -usually- work.  I've found an odd
pattern for these videos.  If I boot the system with only my wifi connection
active, things these videos will play fine.  If I boot with my GigE connection
active, they flicker.  1080i files never work... they always flicker.

If I log out of my X session and the last video I've played was flickering, the
console is toast.  I can log on/off multiple times when I haven't seen the
corruption, -or- if I can play a clean low-res video after the flickering video.
But if my last video played with xv flickers and I log off the system, kdm can't
re-show the login screen.  I momentarily see the text console, then nothing.

When I have the system on the network, I can ssh in even when the laptop is in 
this state and see that X is using 100% of the processor (but the screen is
absolutely blank).  If I go to init 3 or otherwise kill the X process (and kdm
so it doesn't respawn), the LCD screen goes kind of cloudy, but I cannot get
back to a text console.

The only way to regain the local display at this point is a reboot, after
which everything works again.  I'm including my /var/log/messages and an Xorg
log, but I don't know that either is showing a clear indication of the problem.

The flickering video doesn't seem to be the only way to get this locked-up X
process, btw, but it is the most reliable method I have to reproduce the
behavior.
Comment 1 Jeremy Uchitel 2010-02-14 16:00:33 UTC
Created attachment 33299 [details]
/var/log/messages
Comment 2 Jeremy Uchitel 2010-02-14 16:02:25 UTC
Created attachment 33300 [details]
Xorg.0.log
Comment 3 Jeremy Uchitel 2010-05-15 06:30:49 UTC
Created attachment 35671 [details]
Image of flickering stripes when playing video with xv.

I've updated to kernel 2.6.34 rc7, pulled the latest libdrm and ddx updates and downloaded the master snapshot as of 5/14.  My xvideo problems are as bad as ever... I am attaching a snapshot of what I see when I play videos in Xine with xv acceleration on my system.
Comment 4 Ilia Mirkin 2013-08-18 18:09:47 UTC
It appears that this bug report has laid dormant for quite a while. Sorry we haven't gotten to it. Since we fix bugs all the time, chances are pretty good that your issue has been fixed with the latest software. Please give it a shot. (Linux kernel 3.10.7, xf86-video-nouveau 1.0.9, mesa 9.1.6, or their git versions.) If upgrading to the latest isn't an option for you, your distro's bugzilla is probably the right destination for your bug report.

In an effort to clean up our bug list, we're pre-emptively closing all bugs that haven't seen updates since 2011. If the original issue remains, please make sure to provide fresh info, see http://nouveau.freedesktop.org/wiki/Bugs/ for what we need to see, and re-open this one.

Thanks,

The Nouveau Team


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.