Bug 26596 - Mobility Radeon X1700 (r5xx familly) kernel boot/ module load error (regression)
Summary: Mobility Radeon X1700 (r5xx familly) kernel boot/ module load error (regression)
Status: RESOLVED DUPLICATE of bug 25506
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg 6.7.0
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2010-02-16 12:47 UTC by Paul de Vrieze
Modified: 2010-10-11 18:09 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

Kernel dmesg output (each console switch triggers an invalid framebuffer id message) (30.15 KB, text/plain)
2010-02-16 12:47 UTC, Paul de Vrieze
no flags Details
Kernel config (2.6.33-rc7) (65.56 KB, text/plain)
2010-02-16 12:48 UTC, Paul de Vrieze
no flags Details
Xorg.0.log (from working kernel) (27.10 KB, text/plain)
2010-02-16 12:58 UTC, Paul de Vrieze
no flags Details

Description Paul de Vrieze 2010-02-16 12:47:54 UTC
Created attachment 33341 [details]
Kernel dmesg output (each console switch triggers an invalid framebuffer id message)

Kernel mode setting does not work for me any more on my laptop. The last working version is 2.6.32-rc6. 2.6.32-rc8 certainly does not work anymore. I've also tested with various later versions including 2.6.33-rc7.

When using builtin kms, the kernel just hangs when loading. When using a module, the loading does not hang the computer, but blacks the laptop screen (it is completely off, including the backlight). After a while xdm kicks in and I get display. Switching to a virtual console gets back to the no-display situation. Also with a second screen attached (on dvi) there is no display.
Comment 1 Paul de Vrieze 2010-02-16 12:48:48 UTC
Created attachment 33342 [details]
Kernel config (2.6.33-rc7)
Comment 2 Alex Deucher 2010-02-16 12:55:42 UTC
Do you have fbcon loaded?  You need it for a console on the drm framebuffer otherwise you will get a blank display until X starts.
Comment 3 Paul de Vrieze 2010-02-16 12:58:37 UTC
Created attachment 33343 [details]
Xorg.0.log (from working kernel)
Comment 4 Paul de Vrieze 2010-02-16 13:59:21 UTC
I'm not sure about whether fbcon is loaded when built as a module, but it is enabled in the kernel config. It still doesn't fix the case when built into the kernel, or the fact that it doesn't activate my DVI output properly (even running X) even though it sees it (as gdm is nicely asking for username/password on the dvi screen (presumably))
Comment 5 Alex Deucher 2010-02-16 15:31:27 UTC
Can you attach your xorg log and dmesg from 2.6.33-rc7?  Also to clarify:

2.6.32-rc8 and 2.6.33-rc7
- console is blank
- LVDS works when X starts if no DVI monitor is connected
- LVDS and DVI are both blank when X starts if both are connected

- working console and X on all outputs

Does `modprobe fbcon` enable your console?  Does DVI work if you connect it after you've started X on the LVDS?

Comment 6 Paul de Vrieze 2010-02-17 01:56:14 UTC
I've tried it this morning again with .33-rc7 (without the DVI screen connected at all, previously I had the DVI screen connected), and instead of displaying X, it hung. While it did bring up the network etc, it did not actually give me ssh access. Also no X.

Also to clarify, the LVDS (and DVI screen when connected) are completely off, not just blank. As I could not log in, modprobe fbcon was not possible, also I did not get X.
Comment 7 Paul de Vrieze 2010-02-17 05:42:58 UTC
I've just tried things again, now not relying on module autoloading by udev. I've explicitly loaded fbcon (which worked, but did not change the screen). Then I've ran "modprobe radeon" remotely, which resulted in turning of the screen and first for a long time locking the ssh connection. After a long time (a couple of minutes) the console prompt appears, and the ssh connection is usable again. It might be that with the built-in support the same thing would happen, I just never happened to leave the computer alone that long to notice.
Comment 8 Paul de Vrieze 2010-02-17 05:52:38 UTC
Some further info. While running X on the X server with the .33-rc7 kernel, when I move the mouse (with KWin compositing mode enabled) I get "horizontal snow" kind of noise. (btw. Dmesg doesn't say anything)
Comment 9 Alex Deucher 2010-02-17 08:55:25 UTC
This may be a dup of bug 25506.
Comment 10 Paul de Vrieze 2010-02-17 14:56:15 UTC
Indeed the bug seems to be related. Tomorrow I'll try with 33-rc8, as well as taking a look at reverting some of the commits mentioned in that bug.
Comment 11 Paul de Vrieze 2010-03-02 01:30:58 UTC

*** This bug has been marked as a duplicate of bug 25506 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.