Bug 2687 - pgk-config does not always remove '-I/usr/include'
pgk-config does not always remove '-I/usr/include'
Status: RESOLVED WORKSFORME
Product: pkg-config
Classification: Unclassified
Component: src
unspecified
x86 (IA32) Linux (All)
: high normal
Assigned To: Scott James Remnant
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-09 11:22 UTC by Matthias Clasen
Modified: 2005-04-01 11:22 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Clasen 2005-03-09 11:22:14 UTC
From https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=102991:

Description of problem:
pgk-config --cflags (by default) is supposed to remove '-I/usr/include'
from the output cflags, it does not always do this.

Version-Release number of selected component (if applicable):
 0.14.0 

How reproducible:
Every time

Steps to Reproduce:
1. Run these commands
pkg-config --cflags gconfgtk
-> -I/usr/include/gconf/1 -I/usr/include ...

pkg-config --cflags gconf
-> -I/usr/include/gconf/1 -I/usr/include ...

pkg-config --cflags oaf
-> -I/usr/include ..
    
Actual results:
'-I/usr/include' is output

Expected results:
'-I/usr/include' is removed from the output.

Additional info:
PKG_CONFIG_ALLOW_SYSTEM_CFLAGS is not set.
Comment 1 Tollef Fog Heen 2005-04-02 05:22:46 UTC
Can you try again with a reasonably modern pkg-config?  0.14 is very old.

This may also happen if the binary doesn't ship a .pc file and pkg-config falls
back to using gnome-config, since that doesn't do stripping.

If you still can see the problem with a modern pkg-config, please reopen this
bug with a transcript where --debug is enabled.