Bug 27007 - Lines disappear with GL_LINE_SMOOTH
Summary: Lines disappear with GL_LINE_SMOOTH
Status: RESOLVED DUPLICATE of bug 28832
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 7.6
Hardware: Other All
: medium normal
Assignee: marius predut
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-10 18:39 UTC by Søren Hauberg
Modified: 2015-05-06 19:11 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
A program that demonstrates the bug (957 bytes, text/plain)
2010-03-10 18:39 UTC, Søren Hauberg
Details
Image that shows the result of running the demonstration program (1.14 KB, image/png)
2010-03-10 18:39 UTC, Søren Hauberg
Details
Output of 'glxinfo' (16.61 KB, text/plain)
2010-03-11 11:12 UTC, Søren Hauberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Søren Hauberg 2010-03-10 18:39:15 UTC
Created attachment 33930 [details]
A program that demonstrates the bug

In GNU Octave we use OpenGL to plot data. From time to time I see lines that simply disappear in short places. I have been able to reproduce the problem with a simple test case, which I attach. On my machine, this program generates an image which I also attach.

I have an Intel GM45 graphics card and I am using Ubuntu 9.10.
Comment 1 Søren Hauberg 2010-03-10 18:39:55 UTC
Created attachment 33931 [details]
Image that shows the result of running the demonstration program
Comment 2 Michel Dänzer 2010-03-11 03:24:09 UTC
Please attach the glxinfo output.
Comment 3 Søren Hauberg 2010-03-11 11:12:03 UTC
Created attachment 33962 [details]
Output of 'glxinfo'
Comment 4 Eric Anholt 2010-07-21 23:02:54 UTC
I ended up making an automated test for this bug while tracking down another issue, and it looks like QA opened bug report #28832 for it.  I'm going to track this problem there, since we have clear success criteria that way.

*** This bug has been marked as a duplicate of bug 28832 ***
Comment 5 marius predut 2015-05-06 19:04:42 UTC
The patches that fix this bug is up-streamed


bug/show.html.tmpl processed on Feb 24, 2017 at 01:42:20.
(provided by the Example extension).