Bug 27367 - XSyncCreateAlarm causes server to use 100% CPU
Summary: XSyncCreateAlarm causes server to use 100% CPU
Status: RESOLVED WORKSFORME
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: xserver-1.9
  Show dependency treegraph
 
Reported: 2010-03-29 15:32 UTC by Göran Weinholt
Modified: 2010-07-14 12:09 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Test case (1.58 KB, text/x-csrc)
2010-03-29 15:32 UTC, Göran Weinholt
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Göran Weinholt 2010-03-29 15:32:22 UTC
Created attachment 34536 [details]
Test case

I'm using the SYNC extension to create a recurring event. The events happen as I expect them to, but the server uses 100% CPU. The server remains responsive and the CPU usage returns to normal when the client exits. I've attached a small program that triggers the problem.

I'm running Debian lenny (xorg 7.3) but I've also observed this behavior on Debian testing (xorg 7.5).
Comment 1 Keith Packard 2010-07-14 12:09:40 UTC
I tried the test program and cannot reproduce the CPU usage. I'm going to close this bug; please provide more info if you still see this using X server master.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.