Bug 27373 - Xorg segfault
Summary: Xorg segfault
Status: RESOLVED NOTABUG
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nVidia (proprietary) (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Aaron Plattner
QA Contact: Aaron Plattner
URL:
Whiteboard:
Keywords: NEEDINFO
Depends on:
Blocks:
 
Reported: 2010-03-30 09:12 UTC by Marcin
Modified: 2010-03-30 13:29 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg log (10.29 KB, text/plain)
2010-03-30 09:46 UTC, Marcin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin 2010-03-30 09:12:22 UTC
Xorg segmentation fault with xorg-1.7.6. When typing startx, onscreen log says:

could not find "dri" and "dri2" module, and outputs backtrace. Tried with diffrient kernel versions (2.6.30, 2.6.32.2, 2.6.33.1) but no success.
Comment 1 Michel Dänzer 2010-03-30 09:43:16 UTC
Please attach (as opposed to paste) the full Xorg.0.log file showing the problem.
Comment 2 Marcin 2010-03-30 09:46:08 UTC
Created attachment 34547 [details]
Xorg log
Comment 3 Marcin 2010-03-30 09:59:14 UTC
Log says that build operating system differs from the current one, but after recompiling kernel, i've recompiled xorg-server and nvidia-drivers, so this could not be a problem. 
Comment 4 Alan Coopersmith 2010-03-30 10:03:04 UTC
According to the log, you're not using DRI, nor Mesa, but Nvidia's
libglx, and the segfault is in their code, so you'll have to report
this to them:

(II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"

9: /usr/lib64/xorg/modules/extensions/libglx.so (0x7fbd1ee19000+0x288bff) [0x7fbd1f0a1bff]
Segmentation fault at address (nil)
Comment 5 Aaron Plattner 2010-03-30 12:55:58 UTC
Could you please put a breakpoint on LogVWrite and step through to see what it's trying to print when it crashes?
Comment 6 Marcin 2010-03-30 13:29:20 UTC
I think it's solved. Installation nvidia-driver from nvidia.com rather than from gentoo portage works well, so the problem is in gentoo driver ebuild. Thanks anyway.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.