Bug 27406 - [945GM] X crash while clicking Toolbar icon after just back from toolbar application in MeeGo
Summary: [945GM] X crash while clicking Toolbar icon after just back from toolbar appl...
Status: RESOLVED DUPLICATE of bug 26394
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: highest critical
Assignee: Jesse Barnes
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-31 20:09 UTC by Li Peng
Modified: 2010-04-02 12:08 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
handle drawable destruction better (4.07 KB, patch)
2010-04-01 15:39 UTC, Jesse Barnes
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Li Peng 2010-03-31 20:09:52 UTC
This bug is copied from MeeGo bugzilla

http://bugzilla.meego.com/show_bug.cgi?id=76

Build Image(yyyy-mm-dd):
meego-1.0-default-20100316-0002.iso

Hardware Model (on what HW this bug is uncovered): 
945GME based netbook

Bug detailed descriptions(behavior, impact, etc)
===========================================================
X crash, when users enter toolbar app at the 2nd time by clicking the icon of
toolbar

Reproduce Steps(steps,current result, reproduce possibility)
===========================================================
(1)In setting UI, 1st time to click "Toolbar" icon in settings, crash will not
happen and we can enter toolbar app;
(2)In toolbar app, do nothing, just click "All Settings" at the left top to
quit;
(3)In setting UI, click toolbar icon again, crash happens.



Expected result:
===========================================================
no crash.
Comment 1 Li Peng 2010-03-31 20:11:12 UTC
backtrace 

Comment #1 From tf 2010-03-18 06:03:14 PST (-) [reply]
This is a crash in X itself, with the following BT:

#0  0x0807caba in privateExists (key=0xb7820f54, privates=0x921b3d8)
    at privates.c:79
#1  dixLookupPrivate (key=0xb7820f54, privates=0x921b3d8) at privates.c:162
#2  0xb781d1ab in DRI2GetScreen (pScreen=<value optimized out>) at dri2.c:92
#3  0xb781d390 in DRI2DestroyDrawable (pDraw=<value optimized out>)
    at dri2.c:755
#4  0xb72e58c9 in __glXDRIdrawableDestroy (drawable=<value optimized out>)
    at glxdri2.c:111
#5  0xb72d9c38 in DrawableGone (glxPriv=<value optimized out>, 
    xid=<value optimized out>) at glxext.c:163
#6  0x0808c7a2 in FreeResource (id=<value optimized out>, 
    skipDeleteFuncType=<value optimized out>) at resource.c:560
#7  0xb72d6630 in DoDestroyDrawable (cl=<value optimized out>, 
    glxdrawable=29360482, type=<value optimized out>) at glxcmds.c:1269
#8  0xb72d9a96 in __glXDispatch (client=<value optimized out>) at glxext.c:590
#9  0x08089167 in Dispatch () at dispatch.c:439
#10 0x080620ae in main (argc=<value optimized out>, 
    argv=<value optimized out>, envp=<value optimized out>) at main.c:286

Comment 2 Li Peng 2010-03-31 20:13:13 UTC
I did some investigation, using GLX1.2 in clutter won't cause this problem.

So I think this is related to GLX1.3.
Comment 3 Gordon Jin 2010-03-31 23:36:52 UTC
Peng, page-flipping has been disabled in this case, right?
Comment 4 Li Peng 2010-03-31 23:53:19 UTC
(In reply to comment #3)
> Peng, page-flipping has been disabled in this case, right?
> 

yes, page-flipping is disabled.
Comment 5 Jesse Barnes 2010-04-01 15:39:39 UTC
Created attachment 34603 [details] [review]
handle drawable destruction better

This patch fixed similar issues for me; it's queued up for application to the X server along with several other fixes.  See git://people.freedesktop.org/~jbarnes/xserver master branch.
Comment 6 Li Peng 2010-04-01 20:43:27 UTC
(In reply to comment #5)
> Created an attachment (id=34603) [details]
> handle drawable destruction better
> 
> This patch fixed similar issues for me; it's queued up for application to the X
> server along with several other fixes.  See
> git://people.freedesktop.org/~jbarnes/xserver master branch.
> 

I tested this patch, but it doesn't fix this issue.
Should I apply all the the patches in your branch ?
Comment 7 Jesse Barnes 2010-04-02 12:08:01 UTC

*** This bug has been marked as a duplicate of bug 26394 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.