Bug 27473 - Crashes often when closing OpenGL applications
Summary: Crashes often when closing OpenGL applications
Status: RESOLVED DUPLICATE of bug 26394
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL: http://bugs.debian.org/cgi-bin/bugrep...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-05 11:57 UTC by Gustavo Noronha
Modified: 2010-04-06 02:11 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo Noronha 2010-04-05 11:57:50 UTC
I have been having these crashers for a while now, on Debian. I have this version of xserver-xorg-core:

kov@couve:~$ dpkg -s xserver-xorg-core | grep Version
Version: 2:1.7.5.902-1

My graphics card is an Intel 965. I found this Debian bug while investigating: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=567677

It may be of interest, because there's a rather detailed investigation of what could be leading to this crash in there. Here's my stack trace:

Program received signal SIGSEGV, Segmentation fault.
0x00000000004340ea in privateExists (privates=0x290, key=0x7f123ae1f9fc)
    at ../../dix/privates.c:79
79      ../../dix/privates.c: No such file or directory.
        in ../../dix/privates.c
(gdb) bt full
#0  0x00000000004340ea in privateExists (privates=0x290, key=0x7f123ae1f9fc)
    at ../../dix/privates.c:79
No locals.
#1  dixLookupPrivate (privates=0x290, key=0x7f123ae1f9fc)
    at ../../dix/privates.c:162
        ptr = <value optimized out>
#2  0x00007f123ac1e2d7 in DRI2GetScreen (pDraw=0x359e7b0)
    at ../../../../hw/xfree86/dri2/dri2.c:78
No locals.
#3  DRI2DestroyDrawable (pDraw=0x359e7b0)
    at ../../../../hw/xfree86/dri2/dri2.c:344
        ds = <value optimized out>
        pPriv = <value optimized out>
#4  0x00007f123b47cb54 in __glXDRIdrawableDestroy (drawable=0x359ee40)
    at ../../glx/glxdri2.c:110
No locals.
#5  0x00007f123b472880 in DrawableGone (glxPriv=0x359ee40, xid=987888124)
    at ../../glx/glxext.c:163
        c = 0x0
#6  0x000000000044ba83 in FreeClientResources (client=<value optimized out>)
    at ../../dix/resource.c:806
        rtype = <value optimized out>
        resources = <value optimized out>
        this = 0x359f720
        j = 3
#7  0x000000000043e210 in CloseDownClient (client=0x3020e10)
    at ../../dix/dispatch.c:3631
        really_close_down = 1
#8  0x00000000004438c8 in Dispatch () at ../../dix/dispatch.c:450
        result = 56227368
        client = 0x3020e10
        nready = 0
        start_tick = 31980
#9  0x0000000000425b9a in main (argc=9, argv=0x7d52c8,
    envp=<value optimized out>) at ../../dix/main.c:285
        i = 1
        alwaysCheckForInput = {0, 1}
Comment 1 Julien Cristau 2010-04-06 02:11:20 UTC

*** This bug has been marked as a duplicate of bug 26394 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.